Homepage Garage Wiki Register Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > CAMARO6.com General Forums > ZL1 Discussions


Bigwormgraphix


Post Reply
 
Thread Tools
Old 08-22-2020, 11:57 AM   #1
Smokin19

 
Drives: 19' ZL1 A10, w/pdr
Join Date: Sep 2014
Location: S.W. ohio
Posts: 1,406
Want to be cool?

I recently ordered some new machined aluminum vlv covers to replace mine. Took off the coil covers in anticipation of putting on new covers (not here yet). The other day noticed the engine temp was not 210 as usual but, 190. Went to a cruise, again noticed the temp running lower. Had to take some picks for my buddies, they didn't believe me. Well here they are. Running the car at cruise in 89 degree temps. One showing cruising and one after I got home with engine heat soaked for couple minutes.

Pics don't lie.
Attached Images
  
__________________
BTR Stg II cam w/ 38% fuel lobe, ARH 2" headers into 3" w/cats, AWE Touring, Kong X port, Weapon X triple ht exchangers, NW 103, Rotofab big gulp, DSX lowside, TCM tune, BMR Lockout, Mustang dyno 720 rwhp, 634 rwtq.
Smokin19 is offline   Reply With Quote
Old 08-22-2020, 02:10 PM   #2
Brudda*Termite
 
Brudda*Termite's Avatar
 
Drives: 2017 Camaro 2SS
Join Date: Mar 2019
Location: Lakeland, Florida
Posts: 418
Interesting. I took all the covers off mine due to AirForce manifold and Katech valve cover installations, but it was running 180 before and after. I'm in central Florida where it's currently melting but it always seems to run 180...
__________________
Gary
2017 2SS A8 White, Bolt-Ons, Prayed Upon
Brudda*Termite is offline   Reply With Quote
Old 08-22-2020, 02:19 PM   #3
Smokin19

 
Drives: 19' ZL1 A10, w/pdr
Join Date: Sep 2014
Location: S.W. ohio
Posts: 1,406
Quote:
Originally Posted by Brudda*Termite View Post
Interesting. I took all the covers off mine due to AirForce manifold and Katech valve cover installations, but it was running 180 before and after. I'm in central Florida where it's currently melting but it always seems to run 180...
The coil covers are insulated on the back side, don't know if that traps more heat. Maybe someone else knows.
__________________
BTR Stg II cam w/ 38% fuel lobe, ARH 2" headers into 3" w/cats, AWE Touring, Kong X port, Weapon X triple ht exchangers, NW 103, Rotofab big gulp, DSX lowside, TCM tune, BMR Lockout, Mustang dyno 720 rwhp, 634 rwtq.
Smokin19 is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:49 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2023, vBulletin Solutions, Inc.