Homepage Garage Wiki Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > Technical Camaro Topics > Dragstrip and Launching Discussion


Phastek Performance


Post Reply
 
Thread Tools
Old 09-01-2019, 06:24 PM   #1
arpad_m

 
arpad_m's Avatar
 
Drives: 2018 2SS A8
Join Date: Jul 2017
Location: NJ
Posts: 1,558
Need advice on how to improve ET and trap speed (SS w/Maggie 2300)

So I ran an 11.6 @121.7 earlier today, see timeslip below. My car is the left one (#31). Only the second time at the dragstrip in my life.

Ignoring reaction time for now, my 60' wasn't exactly stellar at 1.8, I know, but what is a bit concerning to me is the car consistently only gained 22-23 mph on the big end all day; I was expecting more like 24-25 mph with my setup.

I ran my Michelin PS4S street tires aired down to 28 psi rear and 35 psi front, and my "technique" was using competitive mode, a short 3-4 second burnout, brake torqueing to 1500 rpm and a steady but not hasty smashing of the pedal to the floor.

Temps from the gauges looked okay, fuel was at 3/8 of the tank, the A8 shifted effortlessly and quickly as usual, I didn't feel any sudden torque management kicking in or any hesitation/slowness in the shifts. Track prep was fairly good.

Unfortunately the track shut down at 3pm, an hour earlier than I had expected, so I don't have a data log because of the general rush and me not wanting to mess with the laptop and hold back the staging line. Will definitely log the runs next time, but for now, do you guys see anything obvious I should look at, besides improving my 60' of course?

I do understand the tires are suboptimal, but there should still be a 0.3-0.4 s improvement in them. What do you pros think? Thanks in advance
Attached Images
 
__________________
2018 Camaro 2SS
G7E A8 NPP MRC NAV | Magnuson Heartbeat TVS2300 | Roto-Fab CAI | JMS PowerMAX voltage booster | LT5 TB | JRE custom tune
1100 - 1/30/18 | 2000 - 1/31/18
3000 - 2/06/18 TPW 2/26/18
3400 - 2/19/18 | 3800 - 2/26/18
4300 - 2/27/18 | 4B00 - 3/01/18
4200 - 3/05/18 | 4800 - 3/14/18
5000 - 3/16/18 | 6000 - 3/19/18
arpad_m is online now   Reply With Quote
Old 09-01-2019, 07:16 PM   #2
Snowblind

 
Snowblind's Avatar
 
Drives: '16 2SS / '05 SRT10 Ram / '65 bu
Join Date: Dec 2015
Location: Philthy
Posts: 915
Take a trip down the Turnpike and hit up the dyno at EFX Tuning, they will get you lined out.....and buy some drag radials homie !!!
__________________
CAI, PIM, PTB, LTH, M6 diff, e85, WR. 10.44@128 1/4
Snowblind is offline   Reply With Quote
Old 09-01-2019, 07:50 PM   #3
Joshinator99
 
Joshinator99's Avatar
 
Drives: 2017 Camaro 2SS A8
Join Date: Aug 2018
Location: Petersham MA
Posts: 529
Just looked up the DA for your run, looks like it was 1750 at 3:00 PM (https://airdensityonline.com/track-h...ay/2019-09-01/). Not bad, but not best run material either. Your trap speed will probably tick up if you can get a DA that’s lower.

Don’t know much about your combo? How much boost are you running? E85? If you’re still on the bone stock fuel system, you probably cannot get much more out of it for now.
__________________
2017 Chevy Camaro 2SS A8 Whipple, Rotofab Big Gulp, LT5 95mm TB, LT4 fueling, AWE Touring CB with PLPs, Katech 160 TS, DSX E85 Kit, 608 RWHP/610 RWTQ, 10.87@128
2019 Toyota Sequoia Limited 4WD (daily driver)
2018 Alfa Romeo Giulia Ti Sport Q4 (hers)
Joshinator99 is offline   Reply With Quote
Old 09-01-2019, 09:41 PM   #4
arpad_m

 
arpad_m's Avatar
 
Drives: 2018 2SS A8
Join Date: Jul 2017
Location: NJ
Posts: 1,558
Quote:
Originally Posted by Snowblind View Post
Take a trip down the Turnpike and hit up the dyno at EFX Tuning, they will get you lined out.....and buy some drag radials homie !!!
Thanks My tune (ECM+TCM+FSCM) is from Ted Jannetty and I've found it very satisfactory so far. Honestly, if I were him and a customer came back with just a slip and no data log, I'd simply tell them to capture a few logs first and then and come back, which I'll do.

Drag radials would be great and I'll get them when the time comes for 10-second passes, it's just that I shot my budget for this year, heh
__________________
2018 Camaro 2SS
G7E A8 NPP MRC NAV | Magnuson Heartbeat TVS2300 | Roto-Fab CAI | JMS PowerMAX voltage booster | LT5 TB | JRE custom tune
1100 - 1/30/18 | 2000 - 1/31/18
3000 - 2/06/18 TPW 2/26/18
3400 - 2/19/18 | 3800 - 2/26/18
4300 - 2/27/18 | 4B00 - 3/01/18
4200 - 3/05/18 | 4800 - 3/14/18
5000 - 3/16/18 | 6000 - 3/19/18
arpad_m is online now   Reply With Quote
Old 09-01-2019, 09:48 PM   #5
arpad_m

 
arpad_m's Avatar
 
Drives: 2018 2SS A8
Join Date: Jul 2017
Location: NJ
Posts: 1,558
Quote:
Originally Posted by Joshinator99 View Post
Just looked up the DA for your run, looks like it was 1750 at 3:00 PM (https://airdensityonline.com/track-h...ay/2019-09-01/). Not bad, but not best run material either. Your trap speed will probably tick up if you can get a DA that’s lower.

Don’t know much about your combo? How much boost are you running? E85? If you’re still on the bone stock fuel system, you probably cannot get much more out of it for now.
Thanks for the DA info Joshinator, I didn't know about this site.

My parts are in my sig, I'm running 7.5 psi with the default pulley that comes with the Maggie. Fuel system is stock LT1, the only upgrade there is the JMS voltage booster for added stability. No flex fuel yet, I'm running 93 pump gas. The car made 560 rwhp and 540 rwtq on the dyno.

It's not that there's something grossly off with this result, I'm a noob anyway I know that without headers, cam and at least an LT4 fuel system or E85 there isn't much more in the cards, just want to know if I did something wrong that is easy to fix No more upgrade money for this season, that is the truth.
__________________
2018 Camaro 2SS
G7E A8 NPP MRC NAV | Magnuson Heartbeat TVS2300 | Roto-Fab CAI | JMS PowerMAX voltage booster | LT5 TB | JRE custom tune
1100 - 1/30/18 | 2000 - 1/31/18
3000 - 2/06/18 TPW 2/26/18
3400 - 2/19/18 | 3800 - 2/26/18
4300 - 2/27/18 | 4B00 - 3/01/18
4200 - 3/05/18 | 4800 - 3/14/18
5000 - 3/16/18 | 6000 - 3/19/18
arpad_m is online now   Reply With Quote
Old 09-01-2019, 10:07 PM   #6
laynlo15

 
laynlo15's Avatar
 
Drives: 2016 1ss A8, Npp
Join Date: Nov 2015
Location: clark, mo
Posts: 5,009
I would think there is something wrong. I can tell you my car ran 10.82@129 the first weekend out after we installed my Maggie. I was making 549/540. My car had no other mods except Roto Fab and drag pack (slicks and skinnies). Your car should be at least be trapping at 125 or more. We were actually running the Magnuson tune at the time, way before I went to work for them. I ran 11.71@119 NA with my drag pack, something ain't right. Obviously you don't have a drag pack but it still seems slow even with street tires.
__________________
2016 1SS, Magnuson 2650 Heartbreaker. NW103, Kent's Hot Rod Garage(Hoosier/MT/Race Star),RPM RB
Big Gulp by Roto-Fab, Livernois, Manley, Lt4 Fueling, VP Race Fuel, Speed Engineering, Tuned by toohighpsi.
9.41@146 (best MPH 147) w/1.35 60ft 6.05@117 1/8 (best 1/8 MPH 118) Employee/Driver
laynlo15 is offline   Reply With Quote
Old 09-01-2019, 10:25 PM   #7
ULTRAZLS1


 
ULTRAZLS1's Avatar
 
Drives: 14 Silverado LTZ Z71, 16 Camaro SS
Join Date: Nov 2009
Location: Jackson, Michigan
Posts: 4,395
Something way off. You 8-10 mph off or so. Near full weight drag pack 450-500 rwhp na bolt on cars will trap that speed or more in that DA all day

We’re you heat soaked ? I would think teds tune would be decent enough

560 rwhp at full weight you should be at least high 120 range

ET is going to suffer with street tires but trap should still be close. And it’s way off. That DA isn’t terrible either.

As Jim mentioned have efx take a look at it
__________________
Black 2016 1SS A8
NA bolt on stock gear stock converter. Pump E85
10.66@128.1 +750 DA
490RWHP/487RWTQ
ULTRAZLS1 is offline   Reply With Quote
Old 09-01-2019, 10:29 PM   #8
arpad_m

 
arpad_m's Avatar
 
Drives: 2018 2SS A8
Join Date: Jul 2017
Location: NJ
Posts: 1,558
Quote:
Originally Posted by laynlo15 View Post
I would think there is something wrong. I can tell you my car ran 10.82@129 the first weekend out after we installed my Maggie. I was making 549/540. My car had no other mods except Roto Fab and drag pack (slicks and skinnies). Your car should be at least be trapping at 125 or more. We were actually running the Magnuson tune at the time, way before I went to work for them. I ran 11.71@119 NA with my drag pack, something ain't right. Obviously you don't have a drag pack but it still seems slow even with street tires.
Sheesh, I should've logged that last run. Will try to come back with that next time. The car didn't feel weaker than usual, no weird noises (apart from some crap moving around inside the cabin) or bad shifts, no unexpected readings, no codes, it may be something with the tune or the gas or both...

I have a dash cam video of the run in case you can spot something: https://www.dropbox.com/s/jsvyawbtv1...35_EF.mp4?dl=0 (you might need to download it, the preview doesn't always work).
__________________
2018 Camaro 2SS
G7E A8 NPP MRC NAV | Magnuson Heartbeat TVS2300 | Roto-Fab CAI | JMS PowerMAX voltage booster | LT5 TB | JRE custom tune
1100 - 1/30/18 | 2000 - 1/31/18
3000 - 2/06/18 TPW 2/26/18
3400 - 2/19/18 | 3800 - 2/26/18
4300 - 2/27/18 | 4B00 - 3/01/18
4200 - 3/05/18 | 4800 - 3/14/18
5000 - 3/16/18 | 6000 - 3/19/18
arpad_m is online now   Reply With Quote
Old 09-01-2019, 10:45 PM   #9
arpad_m

 
arpad_m's Avatar
 
Drives: 2018 2SS A8
Join Date: Jul 2017
Location: NJ
Posts: 1,558
Quote:
Originally Posted by ULTRAZLS1 View Post
Something way off. You 8-10 mph off or so. Near full weight drag pack 450-500 rwhp na bolt on cars will trap that speed or more in that DA all day

We’re you heat soaked ? I would think teds tune would be decent enough

560 rwhp at full weight you should be at least high 120 range

ET is going to suffer with street tires but trap should still be close. And it’s way off. That DA isn’t terrible either.

As Jim mentioned have efx take a look at it
Could've been heat soak, when they announced the early shutdown I was rushing to get at least two more runs in. Indeed that white Vette in the video looks roughly the same as my car in terms of acceleration, talked to him afterwards and he was NA, headers and cam only.

I'll reach out to Ted first for another look at the tune in light of this. I did ask him for a relatively conservative tune, so I'm not saying there is anything wrong with it, and I'll definitely have to log.

Thanks a lot guys for the input, I'll try to get to the bottom of this.
__________________
2018 Camaro 2SS
G7E A8 NPP MRC NAV | Magnuson Heartbeat TVS2300 | Roto-Fab CAI | JMS PowerMAX voltage booster | LT5 TB | JRE custom tune
1100 - 1/30/18 | 2000 - 1/31/18
3000 - 2/06/18 TPW 2/26/18
3400 - 2/19/18 | 3800 - 2/26/18
4300 - 2/27/18 | 4B00 - 3/01/18
4200 - 3/05/18 | 4800 - 3/14/18
5000 - 3/16/18 | 6000 - 3/19/18
arpad_m is online now   Reply With Quote
Old 09-04-2019, 09:56 AM   #10
arpad_m

 
arpad_m's Avatar
 
Drives: 2018 2SS A8
Join Date: Jul 2017
Location: NJ
Posts: 1,558
At the moment it looks like the intercooler pump failed and I was running with no S/C coolant circulation. Working with JRE on the fix and I'll get back with updates later.
__________________
2018 Camaro 2SS
G7E A8 NPP MRC NAV | Magnuson Heartbeat TVS2300 | Roto-Fab CAI | JMS PowerMAX voltage booster | LT5 TB | JRE custom tune
1100 - 1/30/18 | 2000 - 1/31/18
3000 - 2/06/18 TPW 2/26/18
3400 - 2/19/18 | 3800 - 2/26/18
4300 - 2/27/18 | 4B00 - 3/01/18
4200 - 3/05/18 | 4800 - 3/14/18
5000 - 3/16/18 | 6000 - 3/19/18
arpad_m is online now   Reply With Quote
Old 09-04-2019, 10:05 AM   #11
ULTRAZLS1


 
ULTRAZLS1's Avatar
 
Drives: 14 Silverado LTZ Z71, 16 Camaro SS
Join Date: Nov 2009
Location: Jackson, Michigan
Posts: 4,395
So you were heat soaked to the max

Get car sorted you will pick up big time
__________________
Black 2016 1SS A8
NA bolt on stock gear stock converter. Pump E85
10.66@128.1 +750 DA
490RWHP/487RWTQ
ULTRAZLS1 is offline   Reply With Quote
Old 09-04-2019, 11:08 AM   #12
Umbriel
 
Drives: 2016 Camaro SS
Join Date: Sep 2018
Location: Bartlett, TN
Posts: 638
Yeah something is way off for sure, I trapped 122 mph and picked up 26 mph on the back end with just cam, headers, converter and drag pack.
Umbriel is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:41 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.