Homepage Garage Wiki Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > Technical Camaro Topics > Dragstrip and Launching Discussion


Gen5DIY


Post Reply
 
Thread Tools
Old 08-23-2019, 11:47 AM   #1
17SS
 
Drives: Chevy Camaro 2SS
Join Date: Aug 2019
Location: Florida
Posts: 5
First pass with 17 SS

Been reading a lot on here since I got the car 2 weeks ago. Last night was the first dry night that the track was open. Car has a K&N cold Air and Flowmaster Mufflers from previous owner. DA was a terrible 2325. Took a couple passes to get a decent launch on the stock tires. Track prep was bad as well but got a decent 1.87 60'. Ran a 12.53 @ 110.61. Mph was lower than I thought it would be. Does that seem about right? Was hoping for low 12s but guess I'll have to wait for better weather. Planning on a tune pretty soon as well. Hoping its about where it should be. May put new plugs in it just to be sure. Any info would be a big help.

Thanks
Attached Images
 
17SS is offline   Reply With Quote
Old 08-23-2019, 11:55 AM   #2
grampa_ss
 
grampa_ss's Avatar
 
Drives: 2016 Camaro 2SS
Join Date: Apr 2017
Location: Stansbury Park, Utah
Posts: 640
I'd say on par. I ran 12.44@111.7 at around 2780 DA.
__________________
2016 2SS, MRC, NPP, A8, Summit White.
Procharger P-1X,Stage II,std bypass, 3.9 pulley, Alky Meth kit.
GM Dark tail lights & 3rd brake light. C7 ZL1 splitter and side skirts.
11.002 @127 - DA+2900
grampa_ss is offline   Reply With Quote
Old 08-23-2019, 11:58 AM   #3
17SS
 
Drives: Chevy Camaro 2SS
Join Date: Aug 2019
Location: Florida
Posts: 5
Ok Thanks, good to know I'm not far off. Remember what your 60' was?
17SS is offline   Reply With Quote
Old 08-23-2019, 12:33 PM   #4
Umbriel
 
Drives: 2016 Camaro SS
Join Date: Sep 2018
Location: Bartlett, TN
Posts: 638
I ran 12.2 @ 114 mph completely stock with a 1.9 60 foot time. Don't remember the DA that day though.
Umbriel is offline   Reply With Quote
Old 08-23-2019, 01:13 PM   #5
grampa_ss
 
grampa_ss's Avatar
 
Drives: 2016 Camaro 2SS
Join Date: Apr 2017
Location: Stansbury Park, Utah
Posts: 640
Quote:
Originally Posted by 17SS View Post
Ok Thanks, good to know I'm not far off. Remember what your 60' was?
yep.
60' 1.867
330 5.259
660 8.044
MPH 89.72
1000 10.435
1320 12.449
MPH 111.73
__________________
2016 2SS, MRC, NPP, A8, Summit White.
Procharger P-1X,Stage II,std bypass, 3.9 pulley, Alky Meth kit.
GM Dark tail lights & 3rd brake light. C7 ZL1 splitter and side skirts.
11.002 @127 - DA+2900
grampa_ss is offline   Reply With Quote
Old 08-23-2019, 05:47 PM   #6
6spdhyperblue

 
Drives: 6spd
Join Date: Aug 2013
Location: US
Posts: 1,949
It’s August in Florida. That’s what happens lol

Btw these plus last forever. I wouldnt start thinking about changing until 60
6spdhyperblue is offline   Reply With Quote
Old 08-23-2019, 06:23 PM   #7
s346k
 
s346k's Avatar
 
Drives: 18 1SS 1LE
Join Date: Jun 2012
Location: indiana
Posts: 246
op: stick or auto? the car does ok to the 1/8 and then leisurely runs the back half. i have an m6 car, i’ve had to pedal every pass after the 1/8 in it so far and still managed to pick up 25+ mph on the top half.
__________________
2016+ camaro: everyone’s first car
s346k is offline   Reply With Quote
Old 08-28-2019, 12:27 PM   #8
17SS
 
Drives: Chevy Camaro 2SS
Join Date: Aug 2019
Location: Florida
Posts: 5
A8 Auto. It was shifting into 5th just before the end of the pass. Think that was hurting the mph some. Was Leaving it in D and letting the car do the shifting. Seems like you can feel the torque management pulling power too
17SS is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:41 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.