Homepage Garage Wiki Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > Engine | Drivetrain | Powertrain Technical Discussions > V6 LGX Engine, Exhaust, and Bolt-Ons


Phastek Performance


Post Reply
 
Thread Tools
Old 04-01-2021, 01:07 AM   #1
Eric.18RS
 
Drives: Chevrolet Camaro
Join Date: Nov 2020
Location: Texas
Posts: 19
DownPipe CEL O2 Sensor problem

I have ARH DownPipes with cats on my Camaro v6 , and I’m getting the cel just for my passenger downstream o2 sensor , i replaced the o2 sensor and after disconnected the battery and stuff but after 10 miles of driving the cel came back on . Any suggestions on what i should do ? Thanks

Last edited by Eric.18RS; 04-09-2021 at 05:16 PM.
Eric.18RS is offline   Reply With Quote
Old 04-01-2021, 09:11 AM   #2
Spudsmaro
 
Drives: Chevy Camaro 2018 3.6l v6
Join Date: Jul 2019
Location: MD
Posts: 64
Quote:
Originally Posted by Eric.18RS View Post
I have ARH DownPipes with cats on my Camaro v6 , and Iím getting the cel just for my passenger downstream o2 sensor , i replaced the o2 sensor and after disconnected the battery and stuff but after 10 miles of driving the cel came back on . Any suggestions on what i should do ? Thanks
Two things you can do, add defoulers to your o2 sensors to make them read less exhaust gas.

Or you can have your tuner disable the codes.

The fact that you have this issue with the catted downpipe is weird tho maybe try contacting ARH.

I have the catless downpipes from ARH and I had these error codes for both banks p0420 and p0430 and even after installing defoulers they still appeared so I had to get my tuner to disable the codes via tune.

Hope I pass emissions 😛
Spudsmaro is offline   Reply With Quote
Old 04-08-2021, 12:33 AM   #3
Eric.18RS
 
Drives: Chevrolet Camaro
Join Date: Nov 2020
Location: Texas
Posts: 19
Quote:
Originally Posted by Spudsmaro View Post
Two things you can do, add defoulers to your o2 sensors to make them read less exhaust gas.

Or you can have your tuner disable the codes.

The fact that you have this issue with the catted downpipe is weird tho maybe try contacting ARH.

I have the catless downpipes from ARH and I had these error codes for both banks p0420 and p0430 and even after installing defoulers they still appeared so I had to get my tuner to disable the codes via tune.

Hope I pass emissions 😛
First I'm trying to fix it without disabling the code that would be my last bet, i tried contacting them but not a word back. If i was to add defoulers do i add them to just that one o2 or both sides? Iím just very confused on why Iím getting the check engine light still when i got cats still and i replaced the o2 sensor lol
Eric.18RS is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:58 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.