Homepage Garage Wiki Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


JDP Motorsports


Post Reply
 
Thread Tools
Old 02-15-2018, 11:24 PM   #1
Mahero
 
Drives: 2017 Camaro 2SS
Join Date: Jan 2018
Location: New Orleans, Louisiana
Posts: 25
2017 Camaro 2SS - Radio Problems Report

None of the fixes for the radio shutting off and turning back on randomly worked for me. Just wanted to post this so others searching can have some idea of what may be the problem on the 2017's.

Steps to take to fix yourself:

1. Pull fuses in trunk for the display (should be in the middle of fuse box)

2. Battery Pull for 15 Minutes

If these steps don't work for you which was my situation. Then, if it's a 2016 it may need a software update for the radio. However, 2017 Camaro's should already have this update.

I brought my car to the dealership and the HMI module was fried most dealerships won't have this part so expect them to have to order it.

This happened at 19530 miles on my car.
Mahero is offline   Reply With Quote
Old 02-16-2018, 04:48 AM   #2
yoyochall
 
Drives: 2017 Camaro RS
Join Date: Jan 2018
Location: Saudi Arabia
Posts: 5
So I'm not alone with this issue.

Now almost 10 people are reporting the same thing with the 2017 model...
yoyochall is offline   Reply With Quote
Old 02-16-2018, 07:21 AM   #3
Childs Play
Wadu Hek?
 
Childs Play's Avatar
 
Drives: 2017 Camaro SS
Join Date: Jan 2012
Location: Houston, TX.
Posts: 623
I've had it happen once where the radio and screen just turned off on me for about a minute and then came back on while driving.

Early 2017 model (May 2016 Build).

I haven't had it happen since. I've seen it happen on other GM vehicles though too.
__________________
H-Town Camaro Club

Past Rides:
2012 Camaro 2SS/RS M6
2012 Camaro ZL1 A6

Current Ride:
2017 Camaro 2SS M6 w/ GM Performance Intake
Childs Play is offline   Reply With Quote
Old 02-25-2018, 11:51 PM   #4
Doug kj6aco
 
Doug kj6aco's Avatar
 
Drives: 2017 1LT RS M6
Join Date: Jun 2017
Location: Oceanside, CA
Posts: 61
Jumped in my car yesterday and no display after startup
unpluged both phone and flashdrive
Than I got this display. Drove straight to the dealer and they did a complete reboot and software upgrade, works great now.
Attached Images
 
Doug kj6aco is offline   Reply With Quote
 
Post Reply

Tags
2017, 2ss, camaro, radio

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:21 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.