Homepage Garage Wiki Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > Technical Camaro Topics > Camaro DIY & HOW-TO instructions & discussions


Emblempros


Post Reply
 
Thread Tools
Old 01-19-2020, 06:44 AM   #85
bereic
 
bereic's Avatar
 
Drives: Camaro SS 2018 Convertible
Join Date: Apr 2019
Location: Switzerland
Posts: 30
all those who installed the Oxilam LED bulbs... any issues until now? Or still working fine?
bereic is offline   Reply With Quote
Old 01-19-2020, 09:36 AM   #86
arpad_m


 
arpad_m's Avatar
 
Drives: 2018 2SS A8
Join Date: Jul 2017
Location: NJ
Posts: 2,661
Quote:
Originally Posted by cmitchell17 View Post
Yeah mine worked fine. The backup lights will give you problems though, unless there is a special backup light that I don't know about. The backup light leds will stay on when there is no backup light power. They will stay very dim though, I've had mine for a few days and overnight and it hasn't run my battery down. The bcm will usually shut down anything running for that long to keep the battery from dying but it dosent work in this case.
You need a resistor for LED reverse lights, that'll prevent the dim residual illumination. Gen5DIY has a harness with a heat shield around the resistor, I've run it since day 1 and works perfect.
__________________
2018 Camaro 2SS
G7E A8 NPP MRC NAV | Magnuson Heartbeat TVS2300 | Roto-Fab CAI | JMS PowerMAX voltage booster | Soler LT5 95mm TB | JRE custom tune
1100 - 1/30/18 | 2000 - 1/31/18
3000 - 2/06/18 TPW 2/26/18
3400 - 2/19/18 | 3800 - 2/26/18
4300 - 2/27/18 | 4B00 - 3/01/18
4200 - 3/05/18 | 4800 - 3/14/18
5000 - 3/16/18 | 6000 - 3/19/18
arpad_m is offline   Reply With Quote
Old 01-19-2020, 10:07 AM   #87
warren3537
 
warren3537's Avatar
 
Drives: 2019 Red Hot ZL1 1LE: 2012 RAM 2500
Join Date: Mar 2012
Location: DeRidder, LA
Posts: 621
Quote:
Originally Posted by bereic View Post
all those who installed the Oxilam LED bulbs... any issues until now? Or still working fine?
I still have had no issues, I took them out of the 1SS when I traded it in for a 19 ZLE and no issues there ether.
warren3537 is offline   Reply With Quote
Old 02-17-2020, 06:31 AM   #88
bereic
 
bereic's Avatar
 
Drives: Camaro SS 2018 Convertible
Join Date: Apr 2019
Location: Switzerland
Posts: 30
Quote:
Originally Posted by warren3537 View Post
I still have had no issues, I took them out of the 1SS when I traded it in for a 19 ZLE and no issues there ether.
I ordered them from Amazon.. now i got these 2 bulbs in the package but 2 resistors as well?!

Did you also got them and did you had to install them?
I'm a bit confused now, as i thought they have built in resistors.

Thank you
bereic is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:39 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.