Homepage Garage Wiki Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > CAMARO6.com General Forums > 2016+ Camaro: 6th Gen Camaro general forum


Bigwormgraphix


Post Reply
 
Thread Tools
Old 12-05-2020, 06:44 PM   #1
ChevyCav
 
Drives: 2017 Camaro SS
Join Date: Dec 2017
Location: East Coast
Posts: 53
Oil Pump Concerns

Hey all, itís been awhile since my last post. My M6 Ď17 1SS is currently getting some work done, heads, cams, intake, etc the whole yard at a reputable shop in PA. Iíve been reading up on the oil pump failures and that Katech just came out with a fix for this. Basically my question is how common is this problem? I feel like it has a bias towards the ZL1s but a few SSís seem to have suffered that fate. My SS has about 36k on the clock with literally no problems.

I figure since my car is already getting the cam installed itís a little too late to ask them to install the katech pump since itís relatively new, so I figure I can install it myself later but in the mean time is this something I should worry about once I get my car back with the added power? What is everyoneís take on the oil pump failures especially since my warranty is essentially null at this time.

Any info would be sweet! Thanks
ChevyCav is offline   Reply With Quote
Old 12-05-2020, 07:15 PM   #2
1LEornothing
 
Drives: 2020 LT1 M6
Join Date: Jan 2016
Location: South, the DEEP south
Posts: 369
It's a bummer you didn't have the katech pump before sending the car in for work, would have a a great opportunity while things were apart. I've only heard of few oil pumps going on the LT1 or LT4, and see it much more frequently in other platforms such as coyotes, voodoos, and hemis. I think you should be alright though.
1LEornothing is offline   Reply With Quote
Old 12-05-2020, 07:53 PM   #3
ChevyCav
 
Drives: 2017 Camaro SS
Join Date: Dec 2017
Location: East Coast
Posts: 53
Quote:
Originally Posted by 1LEornothing View Post
It's a bummer you didn't have the katech pump before sending the car in for work, would have a a great opportunity while things were apart. I've only heard of few oil pumps going on the LT1 or LT4, and see it much more frequently in other platforms such as coyotes, voodoos, and hemis. I think you should be alright though.
Yeah, thatís what Iím thinking. And yeah it sucks man lol, maybe I can call Monday and see if I can get my hands on and have them install while the oil pump is currently out, gotta take advantage of the free labor.
ChevyCav is offline   Reply With Quote
Old 12-06-2020, 07:55 AM   #4
LT4Greg


 
LT4Greg's Avatar
 
Drives: 2017 Camaro ZL1 Coupe
Join Date: May 2016
Location: Georgia
Posts: 4,285
That’s a plan instead of doing it later on!
__________________
ZL1 Coupe, PDR, Exposed carbon fiber hood insert, My Link with Nav, M6 6 speed and Silver Ice Metallic. Mods done: ceramic window tint, GM Accessories Camaro floor mats and Roto-Fab CAI.
LT4Greg is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:56 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.