Homepage Garage Wiki Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > CAMARO6.com General Forums > ZL1 Discussions


Phastek


Post Reply
 
Thread Tools
Old 02-14-2020, 03:24 PM   #1
kdm123
 
Drives: 2018 ZL1-1LE
Join Date: Aug 2019
Location: CA
Posts: 51
Power loss on track

I’m doing a track day and the engine power is cutting off
Nothing is over heating
The traction control and stability control are both fully off
An engine check light is on.
I tried dc the battery but on the first lap the problem continued
It doesn’t happen driving it on the street under full power
Any ideas?
kdm123 is offline   Reply With Quote
Old 02-14-2020, 03:36 PM   #2
staples87
 
Drives: 2017 Camaro ZL1
Join Date: Aug 2018
Location: Bel Air, MD
Posts: 311
After the check engine light came in, did you drive it on the street and the light turned off, or is it permanently on now?

Any mods to the car or is it completely stock?
__________________
'17 Camaro ZL1 M6
staples87 is offline   Reply With Quote
Old 02-14-2020, 03:49 PM   #3
Scottyz
2019 ZL1 1LE MY GOON
 
Scottyz's Avatar
 
Drives: 1980 Z28 Big Red.
Join Date: Dec 2018
Location: Stoney Creek
Posts: 1,188
Wasn’t there issues with air in the coolant system causing the engines to deface or go into limp mode?
I wonder if this is causing the car to drop power????
Scottyz is offline   Reply With Quote
Old 02-14-2020, 04:15 PM   #4
kdm123
 
Drives: 2018 ZL1-1LE
Join Date: Aug 2019
Location: CA
Posts: 51
The engine light was off after the battery dc, but came back on on tge the first lap. It’s still on now.

No overheating
kdm123 is offline   Reply With Quote
Old 02-14-2020, 04:18 PM   #5
kdm123
 
Drives: 2018 ZL1-1LE
Join Date: Aug 2019
Location: CA
Posts: 51
Car is totally stock
kdm123 is offline   Reply With Quote
Old 02-14-2020, 04:32 PM   #6
ssrallyred
 
ssrallyred's Avatar
 
Drives: 2017 Summit White ZL1 M6
Join Date: May 2017
Location: B'ham AL
Posts: 180
Quote:
Originally Posted by kdm123 View Post
Car is totally stock
Get it scanned to see what the code is. then you probably have a starting point.
__________________
Roto Fab/ Kook's LT's,ported blower,removed lid baffle/ 103mm TB' lower pulley and tune.
651/660.
ssrallyred is offline   Reply With Quote
Old 02-14-2020, 07:04 PM   #7
Dixie ZL1
NOXQCES ZL1
 
Drives: 2017 Camaro ZL1
Join Date: Mar 2019
Location: Huntsville AL
Posts: 263
Suspect your SC cooling system has air in it and needs to be bled.
Dixie ZL1 is offline   Reply With Quote
Old 02-14-2020, 11:00 PM   #8
Stephen12ZL1


 
Stephen12ZL1's Avatar
 
Drives: '17 ZL1 A10
Join Date: May 2012
Location: Mechanicsville VA
Posts: 5,875
scan for the code and go from there
__________________
'17 ZL1 A10 Mosaic Black PDR/Nav 2:03.08 VIR Full 11.003@129.2 1.75
'15 Z/28 #325 Black a/c & stereo. 2:10.1 VIR Full (sold)
'12 ZL1 A6 Black 10.52@131 1.55 60' 2:13 VIR Full (sold)
Stephen12ZL1 is offline   Reply With Quote
Old 02-17-2020, 11:47 AM   #9
kdm123
 
Drives: 2018 ZL1-1LE
Join Date: Aug 2019
Location: CA
Posts: 51
I'm taking it to the dealer Friday.
Unfortunately the problem isn't happening in street driving. I hope they can figure it out at the dealer because it really sucks to do all the preparation and cost for a track day only to go home after 2 laps!
The power was cutting out intermittently like when you have fuel starvation, though it could have been ignition just as well. No overheating of any kind.
kdm123 is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:57 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.