Homepage Garage Wiki Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > CAMARO6.com General Forums > 2016+ Camaro: 6th Gen Camaro general forum


BeckyD @ James Martin Chevy


Post Reply
 
Thread Tools
Old 07-21-2019, 06:04 PM   #1
superdave 72
 
Drives: 2018 Camaro SS 2SS Garnet Red
Join Date: Apr 2018
Location: New Braunfels, TX
Posts: 15
HUD

[B][I]Anyone else had trouble with their HUD not working. Mine quit at 2,000 miles. Hear they had to take out the Windshield and Dash to fix it. Don't think I wanna go there. I'll just get used to NOT having it. I'm in for my first free oil change tomorrow at 9AM. Did the first one myself at 800 miles. I'm now at 4,000 miles at 15 months of ownership. My Garage Queen, NEVER driven in the RAIN. Should I question them on what the fix would be??? I guess they will put in 0-30 wt....we will see what they say about the HUD....

superdave 72 is offline   Reply With Quote
Old 07-21-2019, 06:19 PM   #2
Grumpy1
 
Grumpy1's Avatar
 
Drives: 2018 ZL1 Hyper Blue A10
Join Date: Jan 2018
Location: Covington LA
Posts: 342
Can understand why your hesitant I would be too, but I've gotten so use to it I'd have it done.
Grumpy1 is online now   Reply With Quote
Old 07-21-2019, 07:29 PM   #3
Mark114

 
Mark114's Avatar
 
Drives: 2016 2SS Convertible
Join Date: May 2012
Location: St. Louis, MO
Posts: 1,040
Quote:
Originally Posted by superdave 72 View Post
[B][I] Should I question them on what the fix would be??? I guess they will put in 0-30 wt....we will see what they say about the HUD....

Mine turned out to be a bad height switch that had the image too low to see it. Maybe yours will turn out to be something simple too.
Mark114 is offline   Reply With Quote
Old 07-21-2019, 07:45 PM   #4
Warrior102
 
Warrior102's Avatar
 
Drives: 2018 2SS 1LE Coupe 6 speed
Join Date: Aug 2018
Location: Cape Cod
Posts: 212
Have it looked at regardless as it could be just a power issue, you did pay for it. That said I don't care for it as I find myself looking at the dash anyway, and it looks like crap with polarized glasses. Most likely 5W-30 unless you ask for 5W-40, I'd opt for the 40 and I do.
Warrior102 is offline   Reply With Quote
Old 07-22-2019, 07:16 AM   #5
sengli
 
sengli's Avatar
 
Drives: 2018 Bright Yellow ZL1
Join Date: Oct 2013
Location: northern Indiana
Posts: 645
In my last camaro, the HUD was not as clear as the other ones I had, kinda out of focus it looked like. But never quit on me.
__________________
2014 Bright Yellow 2SS RS, M6 Recaros NPP 1LE...turned in
2015 Red Hot ZL1,M6 Recaros,NPP production #853-sold
2017 ZL1 Red Hot M6 PDR,sunroof, exposed carbon,NAV-traded
2018 ZL1 Bright Yellow, A10, PDR, sunroof, carbon hood, and dash
sengli is offline   Reply With Quote
Old 07-22-2019, 07:38 AM   #6
crosive
 
Drives: 17 2ss camaro
Join Date: Aug 2017
Location: central alabama
Posts: 567
ok so this is a stupid question, but you aren't wearing polarized sunglasses while looking at it are you?

I ask, because I did that. 3 days, I thought my hud was out. turns out it was my sunglasses just making it disappear
crosive is offline   Reply With Quote
Old 07-22-2019, 09:10 AM   #7
ItsChristianInHD
 
ItsChristianInHD's Avatar
 
Drives: 2017 Chevrolet Camaro 2LT V6 RS.
Join Date: Mar 2016
Location: OH, Jax FL 2019-2020.
Posts: 706
Mine works fine so far after 2 years.
I’m OCD about my car, so, if somethings broke I want the damn thing fixed especially under warranty. I paid good money for a car so I expect to work fine for a while.
ItsChristianInHD is offline   Reply With Quote
Old 07-22-2019, 08:58 PM   #8
GroundhogSS

 
GroundhogSS's Avatar
 
Drives: '17 2SS convertible'08 Envoy Denali
Join Date: Nov 2011
Location: Cedar Park, Texas
Posts: 2,217
Mine quit one day and I just dropped the negative cable for a few minutes. It came came back and hasn't given me another problem.
__________________
Richard
2017 2SS SIM convertible, A8, NPP, MRC, 56R wheels, GM CAI, Diode Dynamics Side Markers

Delivered: 08/15/2016

GroundhogSS is offline   Reply With Quote
Old 07-23-2019, 02:19 AM   #9
red_johnny
 
red_johnny's Avatar
 
Drives: 2016 Gray 2SS M6
Join Date: Jun 2012
Location: FT Riley, KS
Posts: 659
Quote:
Originally Posted by crosive View Post
ok so this is a stupid question, but you aren't wearing polarized sunglasses while looking at it are you?

I ask, because I did that. 3 days, I thought my hud was out. turns out it was my sunglasses just making it disappear
Happened to me too. Lol
red_johnny is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:44 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.