Homepage Garage Wiki Register Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Phastek Performance


Post Reply
 
Thread Tools
Old 12-08-2021, 04:38 PM   #1
ZachU
 
ZachU's Avatar
 
Drives: 2017 Camaro SS
Join Date: Feb 2014
Location: Fort Worth Texas
Posts: 91
Coolant temperature high? Radiator fan turns on after warm up

Yesterday I was driving the car and noticed my radiator fan was on high. I have an aeroforce gauage and when I looked at the coolant temperature it was at 215+. When I come to a stop and idle the temperature would come down to 206-208 range and rise again when I start driving again. What's weird is the temperature always stayed around 180 even in 100° weather during the summer and now that it's in the 40s this is happening. Coolant is full and I installed a 160° thermostat when I installed my Procharger in June. The gauge on the dash never exceeds 200° despite the Aeroforce gauge showing above 210....could I have a bad thermostat already? Any ideas would be great.

Thanks
__________________
2017 Camaro 1SS
Procharger P1X Stage 2 intercooler
ZachU is offline   Reply With Quote
Old 12-08-2021, 06:48 PM   #2
Rock-It Man
376 cubic inches of fun
 
Rock-It Man's Avatar
 
Drives: 2010 Camaro 2SS A6
Join Date: Jul 2010
Location: MA
Posts: 3,663
The first step in any over-heating diagnosis is a pressure check. If your system is not holding pressure, it will continue to lose coolant and overheat. A lower temp thermostat does nothing to fix overheating and boiling off. All it does is open the flow to the radiator.
Rock-It Man is offline   Reply With Quote
Old 12-08-2021, 07:28 PM   #3
Nitefall17
 
Drives: Camaro 1SS A8 Vert
Join Date: Sep 2018
Location: Tx
Posts: 300
Sounds like the thermostat is stuck open
Nitefall17 is offline   Reply With Quote
Old 12-08-2021, 11:51 PM   #4
ZachU
 
ZachU's Avatar
 
Drives: 2017 Camaro SS
Join Date: Feb 2014
Location: Fort Worth Texas
Posts: 91
Quote:
Originally Posted by Rock-It Man View Post
The first step in any over-heating diagnosis is a pressure check. If your system is not holding pressure, it will continue to lose coolant and overheat. A lower temp thermostat does nothing to fix overheating and boiling off. All it does is open the flow to the radiator.
But it's not losing coolant so I'm not sure about that.....additionally, during normal driving it gets to about 222 and then eventually drops down to 215.....during a pull it gets to 233 and then drops again when I'm done......I'm thinking the coolant temperature sensor needs replacement and I have one coming on Saturday. If I installed a 160° thermostat then wouldn't it be open all the time? Also, this just started yesterday and has been in the same configuration throught the hot Texas heat during the summer and the dash gauge never exceeds 200° but the fan goes to high speed above 212°
__________________
2017 Camaro 1SS
Procharger P1X Stage 2 intercooler
ZachU is offline   Reply With Quote
Old 12-09-2021, 08:33 AM   #5
Nitefall17
 
Drives: Camaro 1SS A8 Vert
Join Date: Sep 2018
Location: Tx
Posts: 300
If the thermostat is sticking open the coolant doesn't have time to slow down in the radiator to cool. That is why when you giving it more RPM it is getting hotter.
I would put the Katech 174 thermostat in.

https://shop.katechengines.com/produ...SAAEgLDzfD_BwE
Nitefall17 is offline   Reply With Quote
Old 12-09-2021, 04:03 PM   #6
ZachU
 
ZachU's Avatar
 
Drives: 2017 Camaro SS
Join Date: Feb 2014
Location: Fort Worth Texas
Posts: 91
Quote:
Originally Posted by Nitefall17 View Post
If the thermostat is sticking open the coolant doesn't have time to slow down in the radiator to cool. That is why when you giving it more RPM it is getting hotter.
I would put the Katech 174 thermostat in.

https://shop.katechengines.com/produ...SAAEgLDzfD_BwE
Thank you for suggesting this....I just ordered it.
__________________
2017 Camaro 1SS
Procharger P1X Stage 2 intercooler
ZachU is offline   Reply With Quote
Old 12-10-2021, 08:13 AM   #7
Nitefall17
 
Drives: Camaro 1SS A8 Vert
Join Date: Sep 2018
Location: Tx
Posts: 300
Anytime
Nitefall17 is offline   Reply With Quote
Old 12-10-2021, 06:15 PM   #8
ZachU
 
ZachU's Avatar
 
Drives: 2017 Camaro SS
Join Date: Feb 2014
Location: Fort Worth Texas
Posts: 91
Well it wasn't the temp sensor as I just changed it and same condition. I'll try the thermostat when it comes in and hopefully that solves it...
__________________
2017 Camaro 1SS
Procharger P1X Stage 2 intercooler
ZachU is offline   Reply With Quote
Old 12-11-2021, 01:19 AM   #9
ZachU
 
ZachU's Avatar
 
Drives: 2017 Camaro SS
Join Date: Feb 2014
Location: Fort Worth Texas
Posts: 91
Looks like after finally finding the answer the problem is indeed the Mishimoto 160° thermostat I installed......Katech 174° will be here Tuesday!
__________________
2017 Camaro 1SS
Procharger P1X Stage 2 intercooler
ZachU is offline   Reply With Quote
Old 12-13-2021, 10:58 AM   #10
Nitefall17
 
Drives: Camaro 1SS A8 Vert
Join Date: Sep 2018
Location: Tx
Posts: 300
Good Deal..
Nitefall17 is offline   Reply With Quote
Old 12-13-2021, 12:22 PM   #11
Gunkk
Thank you Al Oppenheiser!
 
Gunkk's Avatar
 
Drives: Red Hot A10 ZL1 Convertible
Join Date: Jun 2017
Location: Sarasota, FL
Posts: 4,320
Quote:
Originally Posted by ZachU View Post
Looks like after finally finding the answer the problem is indeed the Mishimoto 160° thermostat I installed......Katech 174° will be here Tuesday!
Mishimoto thermostat still garbage after all these years. Folks seem to like their catch cans, but their Tstats are shite.

Glad you got it sorted out.
Gunkk is offline   Reply With Quote
Old 12-13-2021, 12:24 PM   #12
ZachU
 
ZachU's Avatar
 
Drives: 2017 Camaro SS
Join Date: Feb 2014
Location: Fort Worth Texas
Posts: 91
Quote:
Originally Posted by Gunkk View Post
Mishimoto thermostat still garbage after all these years. Folks seem to like their catch cans, but their Tstats are shite.

Glad you got it sorted out.
Yeah, pretty upset about this but at least it's a cheap fix and nothing has been damaged. The new Thermostat comes tomorrow and I'm looking forward to driving my car again. Need to change the supercharger oil also....
__________________
2017 Camaro 1SS
Procharger P1X Stage 2 intercooler
ZachU is offline   Reply With Quote
Old 12-14-2021, 11:00 AM   #13
ctrlz

 
Drives: 2017 2SS, 50th pkg, M6, MRC, NPP
Join Date: Jan 2016
Location: Ocean City, NJ
Posts: 2,141
Quote:
Originally Posted by ZachU View Post
temperature it was at 215+. When I come to a stop and idle the temperature would come down to 206-208 range and rise again when I start driving again. What's weird is the temperature always stayed around 180 even in 100° weather during the summer and now that it's in the 40s this is happening. Coolant is full and I installed a 160° thermostat when I installed my Procharger in June. The gauge on the dash never exceeds 200° despite the Aeroforce gauge showing above 210....could I have a bad thermostat already?
Umm... If you install a 160 T'stat your temp should never exceed 160.
If your temps were going above that, I suspect it was never fully opening. The behavior you describe sounds like it was sticking at different spots and never completely opening. Sounds like junk to me.
ctrlz is offline   Reply With Quote
Old 12-14-2021, 11:39 AM   #14
LiqTenExp

 
LiqTenExp's Avatar
 
Drives: 2017 ZL1
Join Date: Jan 2017
Location: NJ
Posts: 764
Katech t-stat all the way, I had another 180° fail on me in less than 2 years
__________________
2017 Camaro ZL1 Coupe M6 (847whp on Dynojet)
LiqTenExp is online now   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:58 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2022, vBulletin Solutions, Inc.