Homepage Garage Wiki Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > Engine | Drivetrain | Powertrain Technical Discussions > Transmissions


Bigwormgraphix


Post Reply
 
Thread Tools
Old 08-01-2019, 08:06 PM   #1
SGDM

 
SGDM's Avatar
 
Drives: 2016 2SS
Join Date: Nov 2011
Location: North Texas
Posts: 1,412
A8 Quit Today

I was cruising at 60 mph in D and rpm spiked, I let off throttle, rpm settled, pressed throttle and nothing. I coasted into parking lot, popped hood, checked underneath-no fluid, nothing in engine bay. I ran diagnostics on Dash Command and no codes. 15,100 miles on car. I checked trans temp - 150 deg. Turned car off, started car and tried D, R, and manual. No go...

Any suggestions??? Ugh!
__________________


Who Dares...Wins
ADM Performance Built LT4 SC
SGDM is offline   Reply With Quote
Old 08-01-2019, 08:19 PM   #2
Gunkk
Thank you Al Oppenheiser!
 
Gunkk's Avatar
 
Drives: Red Hot A10 ZL1 Convertible
Join Date: Jun 2017
Location: Sarasota, FL
Posts: 2,917
My first guess would be that the pump failed (broken chain?), but I would expect that should throw a code.
Gunkk is offline   Reply With Quote
Old 08-01-2019, 08:48 PM   #3
oldman


 
Drives: SS 6 speed of course
Join Date: Jan 2016
Location: austin
Posts: 2,908
Is it making noise, maybe a shaft failed. bummer these A8 pretty strong.
__________________
2016 to 2017 Stage 1, FBO, ported MSD, 103 TB, E85

2018 Stage 2, P1C, 4.0 pulley, Pray ported heads, Pray stage 1 blower cam, TxSpeed valvetrain, 103mm TB, ported MSD, 1 and 7/8 headers

2019 stage 3: Forged short block 11.5 CR, "defined lope" supercharger cam 33% fuel lobe from Cam Motion, Pray Ported Heads, 3.65 pulley D1X, stage II intercooler, 2 BOVs, DSX secondary low side, DSX E85 sensor, Lingenfelter big bore 2.0, Kooks 2" coated, Lingenfelter injectors, ZL1 driveshaft and half shafts, wrap starter and header, MSD intake, 103 MM TB, BTR valvetrain.
oldman is offline   Reply With Quote
Old 08-01-2019, 08:59 PM   #4
Joshinator99
 
Joshinator99's Avatar
 
Drives: 2017 Camaro 2SS A8
Join Date: Aug 2018
Location: Petersham MA
Posts: 460
I’ll leave this here, just in case...!
https://mxamotorsports.com/product/m...ho-spec-build/
__________________
2017 Chevy Camaro 2SS A8 Whipple, Rotofab Big Gulp, LT5 95mm TB, LT4 fueling, AWE Touring CB with PLPs, Katech 160 TS, DSX E85 Kit, 608 RWHP/610 RWTQ (Mustang Dyno)
2019 Toyota Sequoia Limited 4WD (daily driver)
2018 Alfa Romeo Giulia Ti Sport Q4 (hers)
Joshinator99 is offline   Reply With Quote
Old 08-01-2019, 09:00 PM   #5
SGDM

 
SGDM's Avatar
 
Drives: 2016 2SS
Join Date: Nov 2011
Location: North Texas
Posts: 1,412
Quote:
Originally Posted by oldman View Post
Is it making noise, maybe a shaft failed. bummer these A8 pretty strong.
No noise, a bit of a shudder then it quit.
__________________


Who Dares...Wins
ADM Performance Built LT4 SC
SGDM is offline   Reply With Quote
Old 08-01-2019, 09:02 PM   #6
SGDM

 
SGDM's Avatar
 
Drives: 2016 2SS
Join Date: Nov 2011
Location: North Texas
Posts: 1,412
Quote:
Originally Posted by Joshinator99 View Post
I’ll leave this here, just in case...!
https://mxamotorsports.com/product/m...ho-spec-build/
Thanks brother...
__________________


Who Dares...Wins
ADM Performance Built LT4 SC
SGDM is offline   Reply With Quote
Old 08-01-2019, 09:30 PM   #7
SSport16


 
SSport16's Avatar
 
Drives: 2016 Garnet Red Camaro 2SS
Join Date: Jul 2015
Location: North Carolina
Posts: 5,323
My crapped out of me 2 years ago...started with no shifting out of 1 st gear on the way to the dealer. I literally pulled into the dealers garage bays, they couldn't get it into D or R, $3000k in parts and labor that GM paid under warranty, basically was rebuilt.
__________________
2SS Camaro, Garnet Red, Adrenaline Red, NPP, MRC, A8, 5 Split Spoke Bright Silver Wheels (56W)

1100 Status - 7/24/15 (Ordered)
3800 Status - 10/13/15 (Built)
6000 Status - 12/22/15 (Delivered)
SSport16 is offline   Reply With Quote
Old 08-04-2019, 04:12 PM   #8
SGDM

 
SGDM's Avatar
 
Drives: 2016 2SS
Join Date: Nov 2011
Location: North Texas
Posts: 1,412
It was the TQ converter and pump.
__________________


Who Dares...Wins
ADM Performance Built LT4 SC
SGDM is offline   Reply With Quote
Old 08-04-2019, 06:09 PM   #9
Joshinator99
 
Joshinator99's Avatar
 
Drives: 2017 Camaro 2SS A8
Join Date: Aug 2018
Location: Petersham MA
Posts: 460
Quote:
Originally Posted by SGDM View Post
It was the TQ converter and pump.
What did you end up replacing the TQ converter with (stock or aftermarket)? Glad to hear you’re back up and running.
__________________
2017 Chevy Camaro 2SS A8 Whipple, Rotofab Big Gulp, LT5 95mm TB, LT4 fueling, AWE Touring CB with PLPs, Katech 160 TS, DSX E85 Kit, 608 RWHP/610 RWTQ (Mustang Dyno)
2019 Toyota Sequoia Limited 4WD (daily driver)
2018 Alfa Romeo Giulia Ti Sport Q4 (hers)
Joshinator99 is offline   Reply With Quote
Old 08-04-2019, 10:41 PM   #10
SGDM

 
SGDM's Avatar
 
Drives: 2016 2SS
Join Date: Nov 2011
Location: North Texas
Posts: 1,412
Quote:
Originally Posted by Joshinator99 View Post
What did you end up replacing the TQ converter with (stock or aftermarket)? Glad to hear you’re back up and running.
Thanks man. Stock replace and all covered by GM. The car is sold...
__________________


Who Dares...Wins
ADM Performance Built LT4 SC
SGDM is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:21 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.