Homepage Garage Wiki Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > CAMARO6.com General Forums > 2016+ Camaro: 6th Gen Camaro general forum


Phastek Performance


View Poll Results: LT1 issue: Tell us your story
It’s run prefect since day 1 374 88.84%
Minor issues 22 5.23%
Major repairs 11 2.61%
Full engine replacement. 14 3.33%
Voters: 421. You may not vote on this poll

Post Reply
 
Thread Tools
Old 08-25-2017, 11:08 AM   #29
reeper
 
reeper's Avatar
 
Drives: 2010 HD D/A, 2015 Z06, 2016 2SS
Join Date: Aug 2016
Location: Central WI
Posts: 506
ttt
__________________
2016 Hyper Blue A8 2SS
GM Bodykit: Black
MRR 017 wheels: Black
OEM Blackout tail-lamps
OEM SEMA Grille
35% window tint
Black glow-tie
BMR Suspension (Pretty much everything)
ACS rear-deck spoiler
Rotofab CAI
Lolly-pop red rotors by Madison Powder Coating
reeper is offline   Reply With Quote
Old 08-25-2017, 11:18 AM   #30
KILLA BEE
REDZONE
 
KILLA BEE's Avatar
 
Drives: 2017 1ss Auto,NPP,MRC
Join Date: Mar 2013
Location: Baltimore Md.
Posts: 1,661
Quote:
Originally Posted by TopHatPlus View Post
18500 kms 1 oil change, 87 octane and no issues 4 season of driving.
Wait what, 87 octane????????
__________________
]2017 1ss (Auto), MRC, NPP, suede accents, dealer instAlled all weather floor mats,suede knee pads,8 inch mylink radio, blackout kit, gloss hood/spoiler wrap,2nd cat/muffler delete,
KILLA BEE is offline   Reply With Quote
Old 08-25-2017, 11:41 AM   #31
warren3537
 
warren3537's Avatar
 
Drives: 2019 Red Hot ZL1 1LE: 2012 RAM 2500
Join Date: Mar 2012
Location: DeRidder, LA
Posts: 695
I have 1065 miles on my 17 1SS and the only thing that I have noticed it that it blows black smoke on start up and it has a squeak coming from around the drive belt area, I don't know if that's normal! but I did save my RX catch can off of my 10 1LT, should I install it? I know that a gas engine should not have any oil in the intake.
warren3537 is offline   Reply With Quote
Old 08-25-2017, 11:45 AM   #32
Marty McFlew
Banned
 
Drives: 17 SuperSport Camaro 6 on the Flo'
Join Date: Feb 2016
Location: USA
Posts: 1,508
'17 bought in March. Just over 6k, runs perfect. Knock on wood.
Marty McFlew is offline   Reply With Quote
Old 08-25-2017, 11:49 AM   #33
Marty McFlew
Banned
 
Drives: 17 SuperSport Camaro 6 on the Flo'
Join Date: Feb 2016
Location: USA
Posts: 1,508
Quote:
Originally Posted by warren3537 View Post
I have 1065 miles on my 17 1SS and the only thing that I have noticed it that it blows black smoke on start up and it has a squeak coming from around the drive belt area, I don't know if that's normal! but I did save my RX catch can off of my 10 1LT, should I install it? I know that a gas engine should not have any oil in the intake.
Actually being a direct Injection engine like all modern V8s. They all will get oil in the intake. Its a design flaw/trade off. More power and efficiency but the valves no longer are kept clean with a fuel wash.
Marty McFlew is offline   Reply With Quote
Old 08-25-2017, 11:51 AM   #34
Marty McFlew
Banned
 
Drives: 17 SuperSport Camaro 6 on the Flo'
Join Date: Feb 2016
Location: USA
Posts: 1,508
Quote:
Originally Posted by Bigdog9586 View Post
I put minor issues down as it doesn't run nearly as smooth as my 14 Vette with same engine.
I thought their were changes from the 14' ove rthe 16 and 17 model.
Marty McFlew is offline   Reply With Quote
Old 08-26-2017, 10:27 AM   #35
BluinSC
 
Drives: BVM 1SS
Join Date: Oct 2016
Location: Columbia-Sumter- Florence, SC
Posts: 287
44000 miles no engine issues.

I'm starting to get the afm driving shake though
BluinSC is offline   Reply With Quote
Old 08-26-2017, 12:30 PM   #36
douglas2742
 
douglas2742's Avatar
 
Drives: 2017 Camaro SS coupe
Join Date: Dec 2016
Location: Apple Valley, MN
Posts: 217
Quote:
Originally Posted by reeper View Post
Just trying to grasp the significance of some of the stories floating around here:

I have 2400 miles - no issues but knocking on wood.
My only comment centers around Chevy's highly unusual break in period of 1500 miles before exceeding 4000 RPM and no full throttle starts. EVERY other performance car I've owned used 500 miles as the "go easy" period. I'm thinking maybe there is good justification for this and not adhering to the 1500 mile limit may be causing some of these engine issues? Anyway, I'm not taking any chances and am doing exactly as the manual says.
__________________
1SS, Recaro seats, A8 w/paddle shift extensions, NPP, Magnuson 2300 supercharger, Flowmaster American Thunder exhaust and x-pipe, factory handling kit, Phastek lowering springs, Alpine sound system w/JL sub, Lexani custom 21" wheels, Michelin Super Sport 4S tires, Bigwormgraphix striping, Chevy Performance Brembo big brake kit, darkened taillights and Remin carbon fiber dash kit.

douglas2742 is offline   Reply With Quote
Old 08-26-2017, 01:22 PM   #37
BlackVert2SS
 
Drives: 2016 Camaro SS Convertible
Join Date: Aug 2017
Location: Atlanta, Ga.
Posts: 30
5600 miles- no issues
BlackVert2SS is offline   Reply With Quote
Old 08-26-2017, 09:25 PM   #38
Dallace
 
Dallace's Avatar
 
Drives: Fifty
Join Date: Nov 2016
Location: Kennesaw
Posts: 86
12,500. Engine good. Had to replace torque converter.
__________________
2017 Fifty 2ss/NPP/SEMA rear lights/K&N air filter/LED side markers/Catch can
Dallace is offline   Reply With Quote
Old 08-26-2017, 10:07 PM   #39
camaromike77

 
camaromike77's Avatar
 
Drives: S O L D
Join Date: Aug 2016
Location: Ontario
Posts: 2,107
3,000 miles.....No issues......Knock on wood.....
__________________
Club F1FTY
2017 2SS 50th Anniversary Convertible
Borla S-Type exhaust NPP| GM CAI | Color matched GM side skirts | Color matched 3rd brake light | Big Worm Graphics smoked out tail lights & rear reflectors | Oracle ghosted side markers | LED License plate bulbs | Door striker covers | Jam handle | Engine emblems from RiverCity Creations | 50th Center Console | Black bow ties | Hawk Performance ceramic brake pads | ZL1 Start button | CQuartz ceramic paint finish | Novistretch bra | S O L D
camaromike77 is offline   Reply With Quote
Old 08-26-2017, 11:15 PM   #40
high_climber
 
Drives: 2017 1LE Hyper Blue Metallic
Join Date: Mar 2017
Location: Houston, Tx
Posts: 85
1200mi and I have a coolant leak. They are replacing a cylinder head and gaskets under bulletin to fix. Been in the shop a week now
high_climber is offline   Reply With Quote
Old 08-27-2017, 08:06 AM   #41
jdasnt3

 
jdasnt3's Avatar
 
Drives: 18 Silverado 1500
Join Date: Dec 2015
Location: Bradenton, FL
Posts: 1,722
Almost 20K on this and at most of it modded. I have a great one.
__________________
16 Red Hot 2SS A8: NPP, CAI Cold air, Ported TB, Fasterproms Ported intake, E85 flex, Formatto tuned. 11.80@118 with 1.92 60' (600-700 DA) on stock run flats.
jdasnt3 is offline   Reply With Quote
Old 08-27-2017, 09:09 AM   #42
16silverSS
 
16silverSS's Avatar
 
Drives: 2016 Camaro SS 2ss A8
Join Date: Jun 2016
Location: South Florida
Posts: 49
Complete motor failure at 19,800 miles

New motor already making noises when going into V4. A8 transmission still shifting hard with mild shutter after Gm tsb 3 flush service. Due to bring vehicle back to dealership after 500 miles.
Attached Images
 
16silverSS is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:57 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.