Homepage Garage Wiki Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > Technical Camaro Topics > Road Course/Track and Autocross


BeckyD @ James Martin Chevy


Post Reply
 
Thread Tools
Old 10-21-2020, 11:56 AM   #43
h018871
Geoff
 
h018871's Avatar
 
Drives: 2020 ZL1 Green
Join Date: May 2013
Location: Houston
Posts: 1,370
Another IMHO for you

Consider having them change the filter also. There's no reason not to, it's reasonably cheap

Hope the fluid change solves it
__________________
h018871 is offline   Reply With Quote
Old 10-21-2020, 12:41 PM   #44
TrackClub


 
TrackClub's Avatar
 
Drives: 2020 1LE (previous: 2017 1LE)
Join Date: Mar 2012
Location: Canada, eh!
Posts: 4,468
Quote:
Originally Posted by GunMetalGrey View Post
I took it to my mechanic, and while they determined they could not flush the entire transmission because they lacked the tools, they do believe that it is under filled based on what they saw.

We will see what the dealership says on Thursday when they go check the fluid level before flushing it completely
Lacked the tools? Did they elaborate?

I would be very concerned if the level was low, as that would suggest lack of proper lubrication and hence possible damage to the tranny. Press the dealer for proper analysis here, as if you need a new tranny the time might be NOW. Cheers!
TrackClub is offline   Reply With Quote
Old 10-22-2020, 09:45 PM   #45
GunMetalGrey

 
GunMetalGrey's Avatar
 
Drives: Black 2018 Camaro ZL1
Join Date: Aug 2013
Location: Victoria B.C. Canada
Posts: 827
Quote:
Originally Posted by h018871 View Post
Another IMHO for you

Consider having them change the filter also. There's no reason not to, it's reasonably cheap

Hope the fluid change solves it
You bet, the filter was ordered along with the fluid.
__________________
Tracking is fun, but really living life means looking outside yourself, not just your car window.
GunMetalGrey is offline   Reply With Quote
Old 10-22-2020, 09:46 PM   #46
GunMetalGrey

 
GunMetalGrey's Avatar
 
Drives: Black 2018 Camaro ZL1
Join Date: Aug 2013
Location: Victoria B.C. Canada
Posts: 827
Quote:
Originally Posted by TrackClub View Post
Lacked the tools? Did they elaborate?

I would be very concerned if the level was low, as that would suggest lack of proper lubrication and hence possible damage to the tranny. Press the dealer for proper analysis here, as if you need a new tranny the time might be NOW. Cheers!
Totally agree, talked to the head of the service and parts department to make sure he is personally overseeing it and checking the level before and after the transmission is flushed
__________________
Tracking is fun, but really living life means looking outside yourself, not just your car window.
GunMetalGrey is offline   Reply With Quote
Old 10-22-2020, 09:51 PM   #47
TrackClub


 
TrackClub's Avatar
 
Drives: 2020 1LE (previous: 2017 1LE)
Join Date: Mar 2012
Location: Canada, eh!
Posts: 4,468
Quote:
Originally Posted by GunMetalGrey View Post
Totally agree, talked to the head of the service and parts department to make sure he is personally overseeing it and checking the level before and after the transmission is flushed
TrackClub is offline   Reply With Quote
Old 10-24-2020, 11:31 PM   #48
GunMetalGrey

 
GunMetalGrey's Avatar
 
Drives: Black 2018 Camaro ZL1
Join Date: Aug 2013
Location: Victoria B.C. Canada
Posts: 827
Fluid level was apparently spot on, they then flushed the transmission and said the fluid looked fine.

Next step will be to datalog at the track with HPtuners and laptop
__________________
Tracking is fun, but really living life means looking outside yourself, not just your car window.
GunMetalGrey is offline   Reply With Quote
Old 10-25-2020, 12:52 PM   #49
TrackClub


 
TrackClub's Avatar
 
Drives: 2020 1LE (previous: 2017 1LE)
Join Date: Mar 2012
Location: Canada, eh!
Posts: 4,468
Quote:
Originally Posted by GunMetalGrey View Post
Fluid level was apparently spot on, they then flushed the transmission and said the fluid looked fine.

Next step will be to datalog at the track with HPtuners and laptop
I guess this is good/bad news, as it doesn't point towards any specific culprit. Did they suggest anything specific you should monitor at the track data wise?
TrackClub is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:40 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.