Homepage Garage Wiki Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > Technical Camaro Topics > Audio, Video, Bluetooth, Nav, Radar, Electronics


Phastek Performance


Post Reply
 
Thread Tools
Old 11-04-2020, 04:34 PM   #1
Kristoff
 
Drives: 2017 Camaro
Join Date: Jul 2018
Location: Chicago
Posts: 17
Replacing HMI

My HMI unit is bad. Out of bumper to bumper warranty. Anybody has replaced their HMI units? who can program the HMI unit? can a used one be purchased and installed? thanks in advance!
Kristoff is offline   Reply With Quote
Old 04-19-2021, 07:17 PM   #2
SinSStrNJ
 
Drives: Chevy Camaro 2SS
Join Date: Mar 2019
Location: New Jersey
Posts: 4
Not sure if this is still needed, but check with Gen5DIY. They have some solutions that may work for you.



https://www.gen5diy.com/
SinSStrNJ is offline   Reply With Quote
Old 04-20-2021, 02:46 PM   #3
cellsafemode


 
cellsafemode's Avatar
 
Drives: 2016 Camaro 1LT
Join Date: Jan 2016
Location: California
Posts: 3,350
what makes you think the hmi is bad?

As opposed to say the display being bad.... or a cable between the two being loose/damaged?
cellsafemode is offline   Reply With Quote
Old 04-20-2021, 06:21 PM   #4
Kristoff
 
Drives: 2017 Camaro
Join Date: Jul 2018
Location: Chicago
Posts: 17
I figured it out. It was a bad HMI. I checked cables and voltages. I did go with gen5diy. They programmed it and did the front camera upgrade. It's working like a charm. Thanks for replying.
Kristoff is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:20 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.