Homepage Garage Wiki Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > Engine | Drivetrain | Powertrain Technical Discussions > I4 Turbo LTG Engine, Exhaust, and Bolt-Ons


B&M Racing


Post Reply
 
Thread Tools
Old 03-13-2018, 05:22 PM   #267
ChicagoTommy

 
Drives: 2017 Camaro; 2017 Acadia Denali
Join Date: Jun 2016
Location: Chicago, IL/Williams Bay WI
Posts: 1,073
Quote:
Originally Posted by Start The Machine View Post
I'm scared to put mine back on to be honest. I didn't notice any gains over the stock air box either. I'm starting to think the silicone intake hose and the provided clamps aren't strong enough under boost pressure. I kind of wish I could return it or exchange it for their exaust system until it gets sorted out. I'm not going to bash Mishimoto here, they make quality parts and I really like there products. I just think there might have been an oversight on the intake tube construction and the size of clamps used.
You'll see vacuum before the turbo. Boost comes after the magical spinny thing and discharges into the intercooler charge pipe. If you're seeing boost in you CAI, you've got a major problem.
__________________
This is in no way a personal attack or confrontation, and is not necessarily the view
of the management or sponsors, and the thoughts contained herein are mine,
and is not intended to hurt anyone's feelings or ruin their delicate self esteem, or
to invalidate anyone's personal views or thoughts, nor is it a condemnation of anyone's
race, religion, sex, sexual preferences, handicaps, or intellectual abilities.
ChicagoTommy is offline   Reply With Quote
Old 03-14-2018, 05:35 AM   #268
KingOmen
 
KingOmen's Avatar
 
Drives: 2017 Camaro 2.0T M6 RS sunroof
Join Date: Oct 2016
Location: Miami
Posts: 87
Quote:
Originally Posted by Start The Machine View Post
What was the code # and how did you clear it?
That's the thing it gave me N/A as the code so I'm not 100% sure Which is why I think it a clamp seal issue think the leak was so little I couldn't give off a real code but big enough to act up a bit was weird but so far hasn't come back still running good
KingOmen is offline   Reply With Quote
Old 03-14-2018, 10:20 AM   #269
Mishimoto

 
Mishimoto's Avatar
 
Drives: Mostly Stock
Join Date: Jul 2012
Location: Wilmington, DE
Posts: 1,093
Hey Everyone

Just wanted to follow up for anyone who may have missed my previous message.

We have had a few customers reach out to us about this. As of now, the issue seems to be resolved by simply reinstalling the system and ensuring that all connections are secure. The smallest amount of airflow from the wrong spot can throw readings off and cause an issue such as a CEL.

If reinstalling the system does not resolve your issue, please reach out to us directly for additional troubleshooting / support.

302.762.4501. or support@mishimoto.com

Thanks
-Jake
Mishimoto is offline   Reply With Quote
Old 03-18-2018, 09:30 AM   #270
inkedmcg
 
Drives: 2017 Camaro 2.0 - Black
Join Date: Jan 2017
Location: PA
Posts: 3
Quote:
Originally Posted by Gutling View Post
I finally got to redoing mine and it is gone now. I took it off and reinstalled it, tightening everything and no more surge/hunt. I also had a broken tab on the pcv tube to the intake that may have been assisting in this, but i finally installed my catch cans and this replaced that tube so that may have helped as well.
Did anyone else happen to bust a tab on their CCV hose connection? Im trying to find a replacement but I'm not having much luck.
inkedmcg is offline   Reply With Quote
Old 03-20-2018, 08:43 AM   #271
Thesilent1
 
Drives: 2017 camaro 2.0
Join Date: Mar 2018
Location: Chicago
Posts: 2
@inkedmcg did you try dealer
Thesilent1 is offline   Reply With Quote
Old 03-20-2018, 08:59 AM   #272
Evil-Bee-NH
603 Camaros
 
Evil-Bee-NH's Avatar
 
Drives: 2017 NGM I4 1LT Coupe
Join Date: May 2012
Location: Manchester, NH
Posts: 5,902
CT had the good suggestion of if you snap it just get the MY2016 version without that annoying disconnect.
__________________


MY 2017 I4 CAMARO BUILD JOURNAL | YOUTUBE | INSTAGRAM | 307RWHP - 329 RWTQ HPTUNERS DYNO TUNE
Evil-Bee-NH is offline   Reply With Quote
Old 03-20-2018, 11:28 AM   #273
Gutling
 
Drives: 2017 Chevrolet Camaro 2.0 LT
Join Date: Apr 2017
Location: Dillsboro, NC
Posts: 136
Quote:
Originally Posted by inkedmcg View Post
Did anyone else happen to bust a tab on their CCV hose connection? Im trying to find a replacement but I'm not having much luck.
I broke mine after the fourth time taking it off, but i was replacing it with mishimotos catch can system so it didnt really effect me. If you have to replace it, like someone else said I would get one off a '16 model so then won't have that problem again in the future. Dealer should be able to get it
Gutling is offline   Reply With Quote
Old 03-28-2018, 02:54 PM   #274
Mr.meangreen
 
Mr.meangreen's Avatar
 
Drives: Krypton green 17 Camaro ls 2.0t
Join Date: Mar 2018
Location: Cantley, Qc
Posts: 6
@Mishimoto

The day I bought my car I putted a high performance k&n filter in the oem box, Adding your silicone induction hose to the recipe must bring my car close to the numbers you get with your full intake kit ??
Mr.meangreen is offline   Reply With Quote
Old 03-29-2018, 10:57 AM   #275
Mishimoto

 
Mishimoto's Avatar
 
Drives: Mostly Stock
Join Date: Jul 2012
Location: Wilmington, DE
Posts: 1,093
Quote:
Originally Posted by Mr.meangreen View Post
@Mishimoto

The day I bought my car I putted a high performance k&n filter in the oem box, Adding your silicone induction hose to the recipe must bring my car close to the numbers you get with your full intake kit ??
Hey Mr.meangreen,

Unfortunately, I can only speak in regards to the testing that we conducted. It looks like the induction hose alone produced results of 5 whp and 6 wtq. Our full intake system produced results of 18 whp and 22 wtq. If I had to guess, I'd assume the combination you've mentioned would land somewhere in the middle.

Thanks
-Jake
Mishimoto is offline   Reply With Quote
Old 04-05-2018, 07:56 PM   #276
Mr.meangreen
 
Mr.meangreen's Avatar
 
Drives: Krypton green 17 Camaro ls 2.0t
Join Date: Mar 2018
Location: Cantley, Qc
Posts: 6
Quote:
Originally Posted by Mishimoto View Post
Hey Mr.meangreen,

Unfortunately, I can only speak in regards to the testing that we conducted. It looks like the induction hose alone produced results of 5 whp and 6 wtq. Our full intake system produced results of 18 whp and 22 wtq. If I had to guess, I'd assume the combination you've mentioned would land somewhere in the middle.

Thanks
-Jake
Is it possible to buy your box and filter alone if I want to add it later ?
Mr.meangreen is offline   Reply With Quote
Old 04-06-2018, 08:17 AM   #277
b0bsaget007
 
b0bsaget007's Avatar
 
Drives: 2016 2LT RS Blue Velvet
Join Date: Dec 2016
Location: FL
Posts: 138
Quote:
Originally Posted by Mr.meangreen View Post
Is it possible to buy your box and filter alone if I want to add it later ?
I don't think so. The intake hose to the stock box is a completely different shape than their full intake. The only way to 'upgrade' would be to completely change the intake to their full CAI.
__________________

PC: i5-6600; RX 480 4GB; 16GB DDR4; Samsung 950 PRO 512GB SSD
Car: 2016 Camaro 2LT RS 2.0T 6M Blue Velvet Metallic | ZZP Hi-Flow Catted Downpipe | Injen EVO7300 Cold Air Intake
b0bsaget007 is offline   Reply With Quote
Old 04-06-2018, 10:58 AM   #278
Mishimoto

 
Mishimoto's Avatar
 
Drives: Mostly Stock
Join Date: Jul 2012
Location: Wilmington, DE
Posts: 1,093
Quote:
Originally Posted by Mr.meangreen View Post
Is it possible to buy your box and filter alone if I want to add it later ?
Hey Mr.meangreen,

As @b0bsaget007 mentioned, it does not appear that our kit and the OEM system would be able to work in conjunction with one another. Of course with modification and time, just about anything is possible. But out of the box they do not visually appear to fit together.

While I personally do not have the ability to remove parts from a kit and sell the items individually, we'd be happy to take a look into this for you. Just shoot a quick message to support@mishimoto.com with your request & we'll see what we can do .

Thanks
-Jake
Mishimoto is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:42 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.