Homepage Garage Wiki Register Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


BeckyD @ James Martin Chevy


Post Reply
 
Thread Tools
Old 04-09-2017, 12:28 PM   #1
jaredkoby
 
Drives: Hyper Metallic Blue Camaro
Join Date: Oct 2015
Location: Bowling Green, Ohio
Posts: 24
Water somehow leaked into trunk, Radio doesn't turn on with car

This weekend, my 2016 camaro's radio stopped working, the sound was completely off (couldn't hear the blinkers) and the screen only showed black. The back up camera worked still, but the screen would return to black after. I checked the fuses and found 3/4-1 inch of water in the bottom of the trunk. The radio turned back on last night after about an hour of being off but then this morning it did not turn on at all. I drove intermittently, turning it on and off here and there but it never turned on again. Any suggestions to get the screen to turn on again? I checked the fuses and they all are snug and in all the way, and I also did the turn off the car, open the door, shut it, lock it and wait 5 minute trick but that didn't work. I don't have time to leave the car at the shop until next week, I just need a way to get the radio back on for an emergency trip on friday (I am a student and I have to get home this weekend). Please help.
jaredkoby is offline   Reply With Quote
Old 04-09-2017, 01:14 PM   #2
brettman

 
brettman's Avatar
 
Drives: 2016 Camaro SS
Join Date: Mar 2017
Location: Cleveland, Ohio
Posts: 913
found 3/4-1 inch of water in the bottom of the trunk.

Close the truck when it rains
It's a car not a boat, try to keep out of rivers or lakes.
If still running, Hum your favorite tune driving to school.
I hope that helps.
__________________
2016 Camaro 1SS, Red Hot, K&N Blackhawk intake, Whipple Supercharger, 3.125 pulley, Kooks 2" long tube headers, High flow cats, secondary cats delete, Mishimoto catch can, P3gauge, Lots of dress-up crap that don't make it go any faster.

Car Journal http://www.camaro6.com/forums/showthread.php?t=490975

SC build http://www.camaro6.com/forums/showthread.php?t=492656

Drive, Ride, Fly It Like You Stole It

GO BIG OR GO HOME
brettman is offline   Reply With Quote
Old 04-09-2017, 01:58 PM   #3
jaredkoby
 
Drives: Hyper Metallic Blue Camaro
Join Date: Oct 2015
Location: Bowling Green, Ohio
Posts: 24
Quote:
Originally Posted by brettman View Post
found 3/4-1 inch of water in the bottom of the trunk.

Close the truck when it rains
It's a car not a boat, try to keep out of rivers or lakes.
If still running, Hum your favorite tune driving to school.
I hope that helps.
Yeah the trunk was closed, the water was from a leak that the dealership will have to find and fix, nothing I could do to stop that, a couple of days without a cover because the wind blew it off and the trunk was full of water. But I don't care about that right now, I can mitigate that and watch any more, I just want my radio to work.
jaredkoby is offline   Reply With Quote
Old 05-31-2018, 05:52 PM   #4
thecamaroshadow
 
Drives: 2017 Camaro 2SS Purple Black
Join Date: Dec 2017
Location: Florida
Posts: 11
Quote:
Originally Posted by jaredkoby View Post
Yeah the trunk was closed, the water was from a leak that the dealership will have to find and fix, nothing I could do to stop that, a couple of days without a cover because the wind blew it off and the trunk was full of water. But I don't care about that right now, I can mitigate that and watch any more, I just want my radio to work.
Did they find the leak? Where was it?
I have one too.
__________________
thecamaroshadow is offline   Reply With Quote
Old 06-01-2018, 01:27 PM   #5
HackSaw
 
HackSaw's Avatar
 
Drives: 2017 Camaro SS
Join Date: May 2018
Location: Portland Oregon
Posts: 151
I had a minor water leak in my trunk There was a section of the rubber seal on top that wasnt sitting on the pinch weld properly I had to fight it to go where i wanted but hasnt leaked since
HackSaw is offline   Reply With Quote
Old 06-14-2018, 02:21 PM   #6
thecamaroshadow
 
Drives: 2017 Camaro 2SS Purple Black
Join Date: Dec 2017
Location: Florida
Posts: 11
Quote:
Originally Posted by HackSaw View Post
I had a minor water leak in my trunk There was a section of the rubber seal on top that wasnt sitting on the pinch weld properly I had to fight it to go where i wanted but hasnt leaked since
I also had a pinch. Happy to say the dealer replaced the trunk seal, and I no longer have a leak.
__________________
thecamaroshadow is offline   Reply With Quote
Old 07-16-2018, 08:24 PM   #7
Giri
Soon to be Millionaire
 
Drives: Blue 2016 Camaro
Join Date: May 2016
Location: Gainesville, FL
Posts: 372
https://www.camaro6.com/forums/showthread.php?t=534062 - I have a water leak too
__________________

Giri is offline   Reply With Quote
Old 07-17-2018, 10:37 AM   #8
Rock-It Man
376 cubic inches of fun
 
Rock-It Man's Avatar
 
Drives: 2010 Camaro 2SS A6
Join Date: Jul 2010
Location: MA
Posts: 3,663
You could try contacting OnStar. They may be able to reboot your MyLink system remotely.
Rock-It Man is offline   Reply With Quote
Old 07-17-2018, 12:59 PM   #9
Giri
Soon to be Millionaire
 
Drives: Blue 2016 Camaro
Join Date: May 2016
Location: Gainesville, FL
Posts: 372
Check your fuses. This is what my fuse box looks like
__________________

Giri is offline   Reply With Quote
Old 07-17-2018, 03:27 PM   #10
hitmix300
2016 loaded 2SS
 
hitmix300's Avatar
 
Drives: Maverick X3 Turbo R
Join Date: Feb 2015
Location: United States
Posts: 236
Quote:
Originally Posted by brettman View Post
found 3/4-1 inch of water in the bottom of the trunk.

Close the truck when it rains
It's a car not a boat, try to keep out of rivers or lakes.
If still running, Hum your favorite tune driving to school.
I hope that helps.
real nice contribution.

OP; i had a small leak into my trunk too, it was the seal.
hitmix300 is offline   Reply With Quote
Old 04-24-2021, 06:02 PM   #11
Cf_maro1991
 
Drives: 2017 Chevrolet Camaro 2lt RS
Join Date: Mar 2021
Location: Missouri
Posts: 2
Any updates I just encountered this?

Quote:
Originally Posted by jaredkoby View Post
This weekend, my 2016 camaro's radio stopped working, the sound was completely off (couldn't hear the blinkers) and the screen only showed black. The back up camera worked still, but the screen would return to black after. I checked the fuses and found 3/4-1 inch of water in the bottom of the trunk. The radio turned back on last night after about an hour of being off but then this morning it did not turn on at all. I drove intermittently, turning it on and off here and there but it never turned on again. Any suggestions to get the screen to turn on again? I checked the fuses and they all are snug and in all the way, and I also did the turn off the car, open the door, shut it, lock it and wait 5 minute trick but that didn't work. I don't have time to leave the car at the shop until next week, I just need a way to get the radio back on for an emergency trip on friday (I am a student and I have to get home this weekend). Please help.


Did you get this fixed I just encountered this problem
Cf_maro1991 is offline   Reply With Quote
Old 01-13-2022, 11:05 PM   #12
Omar1
 
Drives: 2016 2SS Red Hot
Join Date: Dec 2015
Location: Greater Los Angeles
Posts: 176
Would you mind sharing your fix for this? Recently encountered the same problem. Replaced the entire fuse box?
__________________
2SS Red Hot 6 Speed, NPP, MRC, 5 sploke black low-gloss, glow-tie
Omar1 is offline   Reply With Quote
Old 01-14-2022, 05:09 PM   #13
Rock-It Man
376 cubic inches of fun
 
Rock-It Man's Avatar
 
Drives: 2010 Camaro 2SS A6
Join Date: Jul 2010
Location: MA
Posts: 3,663
There are a couple of common causes of water in the trunk.

#1: Sunroof drain hose uncoupled in trunk.
#2: Wire harness pinched in trunk rubber seal.
Rock-It Man is offline   Reply With Quote
 
Post Reply

Tags
leak, mylink, no sound, radio, water damage

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:28 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2022, vBulletin Solutions, Inc.