Homepage Garage Wiki Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


BeckyD @ James Martin Chevy


Post Reply
 
Thread Tools
Old 04-21-2019, 05:50 PM   #1
f.d
 
Drives: camaro
Join Date: Feb 2014
Location: Sweden
Posts: 68
STP Fuel additive problem

Hello everyone..

I used STP Fuel additive for no reason ( i thought itís something good for the injectors).
I used STP 5-1 Fuel System Cleaner.

Now I have leaking injectors:

Lost the performance, fuel smell for very long time in cold start.

1- The car running too Rich. LTFT - 23% scanning.
2- fuel in the engine oil. 😵🤯

No codes

Donít ever never use STP fuel cleaner.


New 2018 Camaro SS Auto
8000 km
I donít know what to do!!
Now: I feel like the car start to come back to the life after 2000 km driving, and i changed engines oil, but the fuel getting in the oil pan again.

I will change the engines oil again and see what will happen.
Hope to STP effect expires

Hope you get some warning ⚠️

Donít do what I did.
Good luck 🍀
f.d is offline   Reply With Quote
Old 04-21-2019, 06:27 PM   #2
mrgoodbytes
 
mrgoodbytes's Avatar
 
Drives: '18 2SS/EU (+Recaros) M6 Red Hot
Join Date: Nov 2018
Location: Sweden
Posts: 182
That is crazy. Do you know which of the injectors are leaking?



Will you be troubleshooting/fixing it yourself or going to a dealer?
mrgoodbytes is offline   Reply With Quote
Old 04-21-2019, 07:59 PM   #3
f.d
 
Drives: camaro
Join Date: Feb 2014
Location: Sweden
Posts: 68
It looks all injectors, but I’m going to a workshop 29/April to diagnose , hopefully leaking stops before.

I don’t now, I’m tired.

I will update.

Tomorrow i will change the engines oil again, the engine is suffering cause off the fuel leaking.
f.d is offline   Reply With Quote
Old 04-22-2019, 05:12 PM   #4
SJFGTO
Oh Oh it's Friday Night!
 
SJFGTO's Avatar
 
Drives: 2018 ZL1 1LE Nightfall Gray
Join Date: Jan 2018
Location: Walton Woods
Posts: 635
Well, sounds like more than the STP as the problem. Nevertheless, these engines do not require additives and in fact, they should be avoided. Good quality fuel and GM designated oil is all they need. I hope you get the problem corrected soon!
__________________
2018 Camaro ZL1 1LE NFG; ARH 2Ē headers, catless mids, ARH full exhaust, Lingenfelter 18% lower pulley, ATI Harmonic Balancer, Roto-fab CAI, EE-catch can, TM ported TB, NX Lid, BMR strut tower brace. Aeroforce dual pod interceptor gauges. Tuned by Vengeance Racing!!!

644 HP @ 6250 rpm / 689 trq @ 3660 rpm

Four that wanna own me
Two that wanna stone me
One says she's a friend of mine...
SJFGTO is offline   Reply With Quote
Old 04-23-2019, 01:00 PM   #5
f.d
 
Drives: camaro
Join Date: Feb 2014
Location: Sweden
Posts: 68
Thank you ���� my friends ��������

Today I changed the oil the second time, engines oil smell a way better ( not to much fuel smell), I think the problem start to disappear.

Scanning shows (LTFT -8 %) bank 1 and bank 2 also.

Hopefully 100% disappears next 500 mil or 1000 mil.

I hope to everybody get the warning.
I will update next week

Thank you again
f.d is offline   Reply With Quote
Old 04-29-2019, 03:27 AM   #6
f.d
 
Drives: camaro
Join Date: Feb 2014
Location: Sweden
Posts: 68
God morning.

Today is the day

Bank 1 LTFT is 0%
Bank 2 LTFT is 0%

———
Don’t ever never use STP 5-1 Fuel cleaner.
If you will use it, on your own, and don’t add all the bottle, be wise.

I hope you all get the warning.
Good luck ��
f.d is offline   Reply With Quote
Old 04-29-2019, 04:12 AM   #7
mrgoodbytes
 
mrgoodbytes's Avatar
 
Drives: '18 2SS/EU (+Recaros) M6 Red Hot
Join Date: Nov 2018
Location: Sweden
Posts: 182
Hi f.d thank you for your feedback. Great to hear you got the car sorted again.


Btw, where are you located in Sweden? I am in SkŚne.
mrgoodbytes is offline   Reply With Quote
Old 04-29-2019, 04:51 PM   #8
f.d
 
Drives: camaro
Join Date: Feb 2014
Location: Sweden
Posts: 68
Quote:
Originally Posted by mrgoodbytes View Post
Hi f.d thank you for your feedback. Great to hear you got the car sorted again.


Btw, where are you located in Sweden? I am in SkŚne.
Hello!!
Thank you

Iím in Laholm
f.d is offline   Reply With Quote
Old 05-20-2019, 11:25 AM   #9
f.d
 
Drives: camaro
Join Date: Feb 2014
Location: Sweden
Posts: 68
The problem is back

After changing engines oil the LTFT is -1%, but few days later it’s go to -14% and -16%

It’s really Rich mixture.

LTFT is -6 % while driving, and go to -15 % when i release the throttle.

Oil smell fuel little.

I think, I really have injectors leaking.

any body have idea?

Help!
f.d is offline   Reply With Quote
Old 05-24-2019, 12:36 PM   #10
6spdhyperblue

 
Drives: 6spd
Join Date: Aug 2013
Location: US
Posts: 2,237
Minus 6 is within normal. -15% off throttle is also normal it’s hitting dfco
What are the stft?

If u had leaking injectors you’d know it.
6spdhyperblue is offline   Reply With Quote
Old 05-26-2019, 08:56 AM   #11
TedJS
 
Drives: 2016 Camaro SS
Join Date: Jul 2016
Location: Cleveland, OH
Posts: 92
I think you are driving yourself crazy over nothing. You are seeing a final correction to the base injector pulse width that is completely normal. As long as short term is at or near 0% the system is fine. Probably seeing a periodic correction due to the canister being loaded with fuel vapors etc.

Enjoy your car.
TedJS is offline   Reply With Quote
Old 05-28-2019, 03:40 AM   #12
f.d
 
Drives: camaro
Join Date: Feb 2014
Location: Sweden
Posts: 68
Thank very very much for reply.
.
Every time i change engines oil, the car be perfect and ( LTFT ) go around 0% .
But after 2 days ( LTFT ) go to negative like -5% -10%
And the oil smell fuel
f.d is offline   Reply With Quote
Old 05-31-2019, 03:33 PM   #13
f.d
 
Drives: camaro
Join Date: Feb 2014
Location: Sweden
Posts: 68
I bought the fuel injectors on line for my car today.
I’m just waiting for the dealer to give me reply if the replacement number fits my car.
Please question do I have to update the ECU for the new injectors?
Or just replace them?
f.d is offline   Reply With Quote
Old 06-02-2019, 09:05 PM   #14
avalonandl

 
avalonandl's Avatar
 
Drives: 2017 Camaro 2SS
Join Date: Feb 2009
Location: Troy, michigan
Posts: 1,299
The ONLY fuel injector cleaner you should use is Chevron Techron. Its what GM sells- rebadged.

STP is JUNK
__________________
Garnet 2SS w/ 6spd manual, MRC,NPP,Nav, Kalahari interior. TPW week of 3/6- CAR BUILT Delivered 3/22/17. BFG A/S Comp 2's.
avalonandl is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:14 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.