Homepage Garage Wiki Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > Specific Packages / Variants > 6th gen Camaro Convertible


JUICEDMOTORSPORTS


Post Reply
 
Thread Tools
Old 06-21-2019, 07:14 PM   #43
ArmanSS
 
ArmanSS's Avatar
 
Drives: 2018 Camaro 2SS Convertible
Join Date: Jun 2019
Location: Jacksonville, FL
Posts: 89
Same thing happened to me. The panel spring broke and took it to a dealer in Orlando, they fixed it during the hour or so that I waited for my vehicle. They have seen this before so they keep the part in stock. I was so happy with my experience. Sorry to hear some of you guys didn't have such great experiences. It really does depend on the dealer and the problems they have encountered previously to better serve the next guy with the same issue. Props to Starling Chevorlet.
__________________

Last edited by ArmanSS; 06-21-2019 at 07:15 PM. Reason: didnt finish
ArmanSS is offline   Reply With Quote
Old 06-27-2019, 04:22 PM   #44
Georgia Vert
 
Georgia Vert's Avatar
 
Drives: 18 Chevrolet Camaro SS Convertible
Join Date: Feb 2019
Location: Georgia
Posts: 5
Took mine in on Tuesday and got it back yesterday. While it was there I had them go ahead and do the tranny flush. We will see if that cures the dreaded rumble strip feeling that the transmission has from time to time. I will keep everyone posted.
Georgia Vert is offline   Reply With Quote
Old 06-29-2019, 08:05 AM   #45
sklippi2018
 
sklippi2018's Avatar
 
Drives: 2018 Camaro SS
Join Date: Apr 2019
Location: Stafford, VA
Posts: 31
Well hate to have to join "broken panel" club but I just had this happen to me a couple of days ago. Got off work, picked up car at lot, and put top down. Heard a cracking sound which I thought odd but top went down smoothly and went up just as smooth when I got her home. The next day son came to pick me up for lunch and when I put the top down, via remote, I noticed the panel cover was gone. SMH Went to dealer to get it looked at but it was late so now I have an appointment this coming Tuesday. Thanks for sharing all your experiences. Gives me a starting point for service advisor. BTW, the panel is still in but will not move forward when top goes up. I can probably wiggle it to try and snap into place but we'll see.
sklippi2018 is offline   Reply With Quote
Old 07-02-2019, 03:48 PM   #46
sklippi2018
 
sklippi2018's Avatar
 
Drives: 2018 Camaro SS
Join Date: Apr 2019
Location: Stafford, VA
Posts: 31
Got my car back and issue was fixed. Tech said it was a known issue and shouldn't happen again. Top down and rode home!
sklippi2018 is offline   Reply With Quote
Old 07-05-2019, 04:33 PM   #47
Georgia Vert
 
Georgia Vert's Avatar
 
Drives: 18 Chevrolet Camaro SS Convertible
Join Date: Feb 2019
Location: Georgia
Posts: 5
Quote:
Originally Posted by sklippi2018 View Post
Got my car back and issue was fixed. Tech said it was a known issue and shouldn't happen again.
Interesting, the tech at my shop said that it will happen again because the part was poorly engineered. This is also the second time it has happened to my car. The first was on the driver's side and now the passenger side has broken.

I also see that you noted using the remote to drop the top. The first time mine broke I also used the remote to drop the top. I never used the remote to drop the top again until the other night when my second one broke.

It would be wild to know that something different happens when using the remote causing this problem. I will not use the remote again so I will be the test dummy for that group lol

On another note, the tranny is smooth as silk since the flush and refill. So far so good
Georgia Vert is offline   Reply With Quote
Old 07-11-2019, 12:45 AM   #48
lcd550
 
Drives: '17 2LT/RS 2.0T M6 50th Anniv Vert
Join Date: Feb 2019
Location: SoCal
Posts: 96
I just noticed my panels are opened on both the driver's and passenger side when the top is down. I've never heard a pop or loud noise and don't even know how long it's been like that. I've only been driving my car for about 6 weeks and decided to check today.

Hope I"m lucky and it's an easy fix as some of you have mentioned. I'll take it in when I get my oil changed.
Attached Images
 

Last edited by lcd550; 07-11-2019 at 11:28 AM.
lcd550 is offline   Reply With Quote
Old 07-14-2019, 11:20 AM   #49
HogmanZL1
 
HogmanZL1's Avatar
 
Drives: 2018 ZL1 Convertible
Join Date: Oct 2018
Location: Georgia
Posts: 53
I've noticed this thread for a while now and was hoping it wouldnt happen to me. guess my luck ran out. Spirited drive through N. GA mountains yesterday. Monsoon like rain approaching so stopped to put the top up.

The sound that occurred on the passenger side was like a cracking/breaking sound and i quickly stopped raising the top. the damage was already done... the metal bar that slides the panel broke out of its channel, the panel was now jammed, and now im in the same club as everyone else.

With some careful help from a friend, we were able to slowly engage the panel (broken) and get the top up within minutes of the flood rains. Off to the dealer tomorrow. I went from never meeting my dealer 1.5 months ago, to being there every week now it seems. some scheduled maintenance, unfortunately others back to back warranty work.

Will update on the dealer fix and experience once completed.
HogmanZL1 is offline   Reply With Quote
Old 07-16-2019, 09:33 AM   #50
HogmanZL1
 
HogmanZL1's Avatar
 
Drives: 2018 ZL1 Convertible
Join Date: Oct 2018
Location: Georgia
Posts: 53
Quote:
Originally Posted by HogmanZL1 View Post
I've noticed this thread for a while now and was hoping it wouldnt happen to me. guess my luck ran out. Spirited drive through N. GA mountains yesterday. Monsoon like rain approaching so stopped to put the top up.

The sound that occurred on the passenger side was like a cracking/breaking sound and i quickly stopped raising the top. the damage was already done... the metal bar that slides the panel broke out of its channel, the panel was now jammed, and now im in the same club as everyone else.

With some careful help from a friend, we were able to slowly engage the panel (broken) and get the top up within minutes of the flood rains. Off to the dealer tomorrow. I went from never meeting my dealer 1.5 months ago, to being there every week now it seems. some scheduled maintenance, unfortunately others back to back warranty work.

Will update on the dealer fix and experience once completed.

In and out of the dealer this morning and FIXED in one hour. I was surprised and pleased. I thought they would have to order parts. Unfortunately this is common enough that they do keep these parts in stock.
HogmanZL1 is offline   Reply With Quote
Old 07-18-2019, 10:22 AM   #51
john94si
 
john94si's Avatar
 
Drives: 17 2ss vert
Join Date: Dec 2017
Location: orlando
Posts: 89
Quote:
Originally Posted by ArmanSS View Post
Same thing happened to me. The panel spring broke and took it to a dealer in Orlando, they fixed it during the hour or so that I waited for my vehicle. They have seen this before so they keep the part in stock. I was so happy with my experience. Sorry to hear some of you guys didn't have such great experiences. It really does depend on the dealer and the problems they have encountered previously to better serve the next guy with the same issue. Props to Starling Chevorlet.

Thanks mine just broke this week and starling is only an hour from me.. ill try them
john94si is offline   Reply With Quote
Old 07-19-2019, 08:57 AM   #52
sklippi2018
 
sklippi2018's Avatar
 
Drives: 2018 Camaro SS
Join Date: Apr 2019
Location: Stafford, VA
Posts: 31
Quote:
Originally Posted by Georgia Vert View Post
Interesting, the tech at my shop said that it will happen again because the part was poorly engineered. This is also the second time it has happened to my car. The first was on the driver's side and now the passenger side has broken.

I also see that you noted using the remote to drop the top. The first time mine broke I also used the remote to drop the top. I never used the remote to drop the top again until the other night when my second one broke.

It would be wild to know that something different happens when using the remote causing this problem. I will not use the remote again so I will be the test dummy for that group lol

On another note, the tranny is smooth as silk since the flush and refill. So far so good
Tech was probably a little confident but so far so good. Definitely will try the tranny flush and refill.
sklippi2018 is offline   Reply With Quote
Old 07-24-2019, 10:23 AM   #53
john94si
 
john94si's Avatar
 
Drives: 17 2ss vert
Join Date: Dec 2017
Location: orlando
Posts: 89
They have a TSB now to fix it for good.. i have the parts coming in
john94si is offline   Reply With Quote
Old 07-24-2019, 03:32 PM   #54
lcd550
 
Drives: '17 2LT/RS 2.0T M6 50th Anniv Vert
Join Date: Feb 2019
Location: SoCal
Posts: 96
Quote:
Originally Posted by john94si View Post
They have a TSB now to fix it for good.. i have the parts coming in
Thanks for the update! Do you have the TSB # or actual document?

I like to bring the TSBs with me when I go to the dealership so it speeds up teh process.
lcd550 is offline   Reply With Quote
Old 07-25-2019, 05:15 PM   #55
JBLUES
 
JBLUES's Avatar
 
Drives: 2017 6.2 vert
Join Date: Aug 2012
Location: MA
Posts: 98
*raises hand*
Happened to me today.

Found this little beauty rolling around in the roof well.

Any idea what it is?
Attached Images
 

Last edited by JBLUES; 07-25-2019 at 05:24 PM. Reason: add picture
JBLUES is offline   Reply With Quote
Old 07-26-2019, 01:36 AM   #56
lcd550
 
Drives: '17 2LT/RS 2.0T M6 50th Anniv Vert
Join Date: Feb 2019
Location: SoCal
Posts: 96
Quote:
Originally Posted by lcd550 View Post
Thanks for the update! Do you have the TSB # or actual document?

I like to bring the TSBs with me when I go to the dealership so it speeds up teh process.
I believe I found the TSB:
https://static.nhtsa.gov/odi/tsbs/20...39149-9999.pdf
lcd550 is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:20 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.