Homepage Garage Wiki Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > Engine | Drivetrain | Powertrain Technical Discussions > Transmissions


Emblempros


Post Reply
 
Thread Tools
Old 03-06-2020, 02:12 PM   #1
mary2.0
 
Drives: 17 Camaro 2.0 50th Anniversary
Join Date: Oct 2019
Location: Texas
Posts: 11
Transmission failure at 28k??? (A8 2.0turbo)

Hey all. Just got my car back from the dealer for a bit of service.

Anyways, got the car back yesterday. Drove fine for about 30 minutes to an hour. Suddenly, I hit the gas and no go. A lot of hesitation when accelerating at low speeds. Even at high speeds punching the gas wouldn't accelerate normally, but no hesitation at least.

Took it to a muffler shop, thinking it was my o2 sensor throwing the computer out of wack. I do have ZZP downpipe installed and hadn't put the spacer on yet, so it was throwing a code. Muffler shop ran diagnostics. Loose o2 sensor. Put the spacer on, all codes were clear. Great I thought. Maybe once the computer resets or something it will drive fine?

It did drive a bit smoother for a bit. Then I got a transmission hot, idle engine notification and check engine light came on.

Great...I take it back to the dealer. Still under warranty.

My main concern is, why would this happen right when I get it back from the dealer? It has been driving fine for the past year. A few months with the check engine light on even. A little bit of hard driving on my end, but not driving like a maniac consistently like 24 hours at lemans or something.

So they say I need a whole new transmission. At 28k miles. After I get it back from them. (I'm really concerned they did something to my car.) I would think this type of problem would start off small and gradually get worse giving me time to address the issue sooner. But I don't know too much how transmission operates.

Muffler shop suggested I get a tune before taking it to the dealer just to see if it is a timing issue or something with the aftermarket downpipe, but they also said transmission could be the issue.

Should I go get my car back, do the tune? Or is the transmission just completely gone now? Parts are on back order (one customer has been waiting since October) and no loaner cars at the moment (so I have to Uber everywhere, or get a rental for a week at the least).

Thanks for any suggestions or advice you guys may have.

Edit:

Other symptoms:
Reverse would hardly move the car at all, really had to give it some gas, let off, then back on to get it moving.
Cold start and car would barely move giving it quite a bit of gas.
Once the check engine light came on, car wouldn't shift at all.
It felt like the car stalled or something when stopping (only once). Had to shift into park then back into drive to get it going.

Edit2:

Sorry if I'm a bit fussy. It just boggles my mind why this would happen right when I get my car back from the dealer. I'd hate to know if they really did do something or if I just got a bad transmission from the getgo.

Also, does anybody know what the wire that runs across the engine bay up top from the driver side to the passenger side? It's directly under the hood. The passenger side wire looked like it had been snipped.

Last edited by mary2.0; 03-06-2020 at 02:23 PM.
mary2.0 is offline   Reply With Quote
Old 03-06-2020, 02:21 PM   #2
Jb54
 
Drives: 2019 Camaro SS M6
Join Date: Jan 2020
Location: Nebraska
Posts: 72
Let the dealer handle it under your drivetrain warranty. Don't be ridiculous in thinking they did something to it. Stuff happens at the most inconvenient moments in life. I'm sure they will fix it and make it right again.

Last edited by Jb54; 03-06-2020 at 02:25 PM. Reason: Add
Jb54 is offline   Reply With Quote
Old 03-06-2020, 02:28 PM   #3
mary2.0
 
Drives: 17 Camaro 2.0 50th Anniversary
Join Date: Oct 2019
Location: Texas
Posts: 11
Quote:
Originally Posted by Jb54 View Post
Don't be ridiculous in thinking they did something to it. Stuff happens at the most inconvenient moments in life. I'm sure they will fix it and make it right again.
Sorry, I'm a bit paranoid.

There has been a lot of cases in my city about dealers doing sketchy stuff with customers' cars. One guy spent 3500 for service he didn't even need. Dealer only changed spark plugs and oil. (story directly from a dealer service rep. not the same dealer/manufacturer but still)

I don't mind there being a problem. It's just I'm worried about the cause of the problem seeing as it is happening so often.


Edit

4/28/2019
"I went there to change injectors in my truck they charge me $2500 after one weeks I have some problem with my truck .I go back to the shop and they told me it's something else so I decided to go to another 2 shops to check if I have new injectors both of them say and they give that to me black on with that no one changed that.. No Honesty
One of the worst service
And when I called to ask for my money
They naver talk to me"

This is just one review for this dealership. There are countless others of their service department charging for services they don't complete. Even other reviews (same dealer) saying that the car runs worse or new problems arise after getting it back from them. My fault for not checking reviews before taking it to them.
mary2.0 is offline   Reply With Quote
Old 03-06-2020, 02:38 PM   #4
Jb54
 
Drives: 2019 Camaro SS M6
Join Date: Jan 2020
Location: Nebraska
Posts: 72
Mary: I really believe them when they say you need a new tranny, just from the symptoms you describe. I don''t believe it's anything you did to cause it either. The A8 is and has been a problematic transmission. They will take care of it, I'm sure. Please don't take anymore advice from a muffler shop about your transmission problems! This should be covered 100 percent under your warranty.

Last edited by Jb54; 03-06-2020 at 02:40 PM. Reason: Add
Jb54 is offline   Reply With Quote
Old 03-06-2020, 02:43 PM   #5
mary2.0
 
Drives: 17 Camaro 2.0 50th Anniversary
Join Date: Oct 2019
Location: Texas
Posts: 11
Quote:
Originally Posted by Jb54 View Post
Mary: I really believe them when they say you need a new tranny, just from the symptoms you describe. I don''t believe it's anything you did to cause it either. The A8 is and has been a problematic transmission. They will take care of it, I'm sure. Please don't take anymore advice from a muffler shop about your transmission problems! This should be covered 100 percent under your warranty.
Okay. I'm sorry for being so pretentious.

I have read about this transmission having problems often. I will trust your advice and their word and let them handle it. I just need to stop over thinking it. Reading the reviews doesn't help...but I will just take a breather and relax knowing it is at least under warranty.

Thank you.
mary2.0 is offline   Reply With Quote
Old 03-06-2020, 02:51 PM   #6
Jb54
 
Drives: 2019 Camaro SS M6
Join Date: Jan 2020
Location: Nebraska
Posts: 72
You are welcome. I know it stinks, not having your car. GM knows the problem and your car will be better than ever when you get it back. Keep your receipts for a rental and/ or Uber and present them to the dealer for reimbursement. That is the least they could do for you. Good luck Mary. I read your edit above. Are there any other GM dealers near you , that you could talk to?

Last edited by Jb54; 03-06-2020 at 03:03 PM.
Jb54 is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:48 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.