Homepage Garage Wiki Register Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Phastek Performance


Post Reply
 
Thread Tools
Old 06-12-2022, 03:15 PM   #1
homesick
 
Drives: working on one
Join Date: Jan 2010
Location: mars
Posts: 39
Tach bouncing around and fan staying on

I have a 16 camaro ss the tach bounces around and a day or so later the fan stays on and the temperature gauge doesn't rise. Anyone knows the fix for this problem?
homesick is offline   Reply With Quote
Old 06-13-2022, 10:33 AM   #2
KirkH


 
Drives: 2016 2SS M6 Mosaic Blk Met
Join Date: Jun 2016
Location: KY
Posts: 2,903
My fan occasionally stays on after turning off the car. I remove the negative battery cable and it stops. Happens about every 6 months or so.
__________________
Official Detailer of CamaroFest 8 & 9, Examples of my detailing work: https://www.camaro6.com/forums/showt...=521655&page=3
https://www.camaro6.com/forums/showt...=547470&page=2
https://www.camaro6.com/forums/showthread.php?t=527474
No one on Earth has detailed more Camaros.
KirkH is offline   Reply With Quote
Old 06-13-2022, 11:32 AM   #3
drewspr00
 
drewspr00's Avatar
 
Drives: 2016 Camaro 2SS Convertible A8
Join Date: Apr 2019
Location: Huntsville, Alabama
Posts: 132
Temperature guage staying at zero and fans running full blast even after turning car off is solved by replacing the thermostat. Just had the same issue and it is resolved. Tach bounce is a separate issue, I have the same thing on mine, not sure of the solution for it though.
drewspr00 is offline   Reply With Quote
Old 06-13-2022, 11:44 AM   #4
SSDan

 
SSDan's Avatar
 
Drives: 2016 1SS 6MT NPP
Join Date: Feb 2010
Location: Lake Murray, SC
Posts: 2,088
Quote:
Originally Posted by homesick View Post
I have a 16 camaro ss the tach bounces around Anyone knows the fix for this problem?
I don't have a suggestion for the fan issue. Other members have stated they had a bouncing tach that was fixed by adding a ground cable. Note: I added the ground cable to cure slow starter cranking on hot starts but as mentioned others fixed their tach issue with a ground cable too. Worth a shot - easy and cheap to do.

Here is my thread for doing that:

https://www.camaro6.com/forums/showthread.php?t=586153

Good luck and keep us posted.
__________________
2016 Camaro 1SS Hyper Blue 6MT NPP

2010 Camaro 2SS Cam/Headers/CAI/3.91 gears
476 rwhp/440 rwtq (sold)
SSDan is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:09 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2022, vBulletin Solutions, Inc.