Homepage Garage Wiki Register Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > CAMARO6.com General Forums > 2016+ Camaro: 6th Gen Camaro general forum


AWE Tuning


Post Reply
 
Thread Tools
Old 09-14-2020, 03:30 PM   #1
MANNAXMAN
 
MANNAXMAN's Avatar
 
Drives: 2016 Camaro 2SS Convertible
Join Date: Sep 2016
Location: SF Bay Area
Posts: 501
Long Term Owner Experiences

As of this past Labor Day, I've owned my 2016 2SS Convertible 4 years. Over this time, I've had some minor issues and noticed some differences in feature performance compared to when I first bought the car. I'd like to see what other people who have had their car at least three years have experienced. It's one thing to read a thread related to a specific issue, but I'm interested in seeing all of the issues an owner has had.

My list of issues and observations:
There are probably a few other, even more minor issues I've had. Overall, the car has been pretty reliable and free of any major issues so far. *knock on wood*
__________________
2016 Camaro 2SS, Convertible, Summit White, A8, NPP, NAV, Daily Driver (Sept. 2016-Present)
1996 Camaro Z28 with T-Tops (Sold 10.22.16)
1986 Camaro IROC-Z with T-Tops (Sold)
1961 Volkswagen Beetle with Sliding Ragtop Sunroof (2009-Present)
1964 Volkswagen Beetle with aftermarket Sliding Ragtop Sunroof (Sold)
Follow me on Instagram - @gen6_2ss_vert

Last edited by MANNAXMAN; 12-02-2021 at 03:59 PM.
MANNAXMAN is offline   Reply With Quote
Old 09-14-2020, 03:53 PM   #2
SSDan

 
SSDan's Avatar
 
Drives: 2016 1SS 6MT NPP
Join Date: Feb 2010
Location: Lake Murray, SC
Posts: 2,088
I've owned my SS since April 2016 and have 29k miles on it (miles driven have really dropped the last 7 months due to pandemic). The only issue I have is the slow cranking on a hot start (see all the posts about the class action suit for details). The car has never stranded me with a no start but it is unnerving to hear that starter crank so slowly when it happens. The only warranty visit was at 35 months of ownership for the cranking issue. The dealer solution was to replace the battery. Other than that the car has been problem free.

I still get a little excited every time I take it out of the garage! It's been a hoot and still gets admiring looks and compliments.
__________________
2016 Camaro 1SS Hyper Blue 6MT NPP

2010 Camaro 2SS Cam/Headers/CAI/3.91 gears
476 rwhp/440 rwtq (sold)
SSDan is offline   Reply With Quote
Old 09-14-2020, 03:59 PM   #3
1LEornothing

 
Drives: 2020 LT1 M6
Join Date: Jan 2016
Location: South, the DEEP south
Posts: 913
That list inspires confidence coming from a 1st model year car. Being a 2020 m6 hardtop I can expect to never have those minor issues you encountered. Very informative and thanks for sharing, hopefully others chime in.
1LEornothing is offline   Reply With Quote
Old 09-14-2020, 04:06 PM   #4
CamaroChriSS
 
CamaroChriSS's Avatar
 
Drives: 16 1SS M6 Black -previous 00 Z28 M6
Join Date: Oct 2018
Location: DC
Posts: 238
I've had my 16 SS for 2 years with one issue in that run - a dead battery after 5 days parked that required some sort of computer refresh to fix the auto-dipping windows when you open and close the doors.

Other than that completely trouble free.
CamaroChriSS is offline   Reply With Quote
Old 09-14-2020, 04:10 PM   #5
SkySerpent
 
Drives: 2022 Vivid Orange LT1 M6
Join Date: Apr 2018
Location: Canada
Posts: 78
Owner since March 2018. Haven't had to many issues cars been pretty solid especially considering I daily the car and put a decent amount of km's on it. Issues have been: -Chipping paint on corners of spoiler -Broken weld in the exhaust pipe (broke a week after purchase not an issue since) -A8 Vibration issues Really wish I got a manual when I had the opportunity. However I will admit if I exclude the A8... This car is an absolute tank nothing has given me any issues in 75,000km of driving not even rust (Toronto likes salt).
SkySerpent is offline   Reply With Quote
Old 09-14-2020, 04:15 PM   #6
kropscamaro16


 
kropscamaro16's Avatar
 
Drives: 2016 1ss camaro
Join Date: Feb 2016
Location: huntington beach
Posts: 9,219
owned my 16ss since new only issues have been the battery dying 3 years in a bad speaker my steering wheel emblem piece peeling and my tensioner last month going out on me almost 30k now
__________________
16 1SS NIGHTFALL GRAY METALLIC WITH NPP #BECAUSERACECAR #SAVETHEMANUALS
kropscamaro16 is offline   Reply With Quote
Old 09-14-2020, 04:20 PM   #7
PnCRedJwl2SS
Howdy! Pete here...
 
PnCRedJwl2SS's Avatar
 
Drives: 2017 50th Anniv 2SS, A8, NPP, MRC
Join Date: Jul 2009
Location: Schertz, TX
Posts: 1,379
I've had my 2017 2SS Since September of 2016. Currently at approximately 56K miles. Here are my issues so far:

- A8 shudder at 17K miles. 3X flush lasted until 20K miles when shudder returned. Replaced torque converter under warranty. Shudder-free ever since.

- Brake vibration (repaired rotors and pads under warranty). This has happened twice.

- Replaced shifter assembly after micro-switch sensor failed. Would be in "Park" but DIC would say "Shift to Park."

- Recently replaced battery (it was time).

That's pretty much it! This car is a BEAST!
__________________
PnCRedJwl2SS
2017 50th Anniversary Edition, A8, NPP, MRC, w/Sunroof and Glow-tie!
___________________________________________

___________________________________________
Ordered from GM
Delivered to dealership and home 9-16-16
This car is a beast!

Last edited by PnCRedJwl2SS; 09-14-2020 at 06:40 PM.
PnCRedJwl2SS is offline   Reply With Quote
Old 09-14-2020, 04:27 PM   #8
cellsafemode


 
cellsafemode's Avatar
 
Drives: 2016 Camaro 1LT
Join Date: Jan 2016
Location: California
Posts: 3,425
Stock runflats lasted 20k miles and were garbage in wet weather of any kind.
mylink screen died
body panels vibrate when music is playing (both in the rear and front)
A8 shudder after 35k (If you have this or fluid before 2019, get it flushed asap or you'll be buying a new torque converter).
Intermittent failure of reading the coolant temp sensor (clearing the code fixes it)


That's about it thus far. Daily driven since feb of 2016 and have about 37k on it.
cellsafemode is offline   Reply With Quote
Old 09-14-2020, 04:45 PM   #9
Bosse'sBoss

 
Bosse'sBoss's Avatar
 
Drives: '16 Camaro SS 6 spd manual transm.
Join Date: Aug 2012
Location: RGV Texas
Posts: 1,308
Thumbs up

My 2016 Camaro SS MT has been great w/. 25K miles.
Replaced inside mirror under warranty
2 black wheels repainted under warranty
Paid dealer to level my hood
Battery replaced
Radio Bluetooth connection issues. Fixed itself.
__________________
'16 Camaro SS
Prior cars:
'14 Corvette C7 Stingray Z51
'14 Camaro ZL1 w/. Recaro seats
'11 Mustang GT 5.0 w. track package
'02 Porsche 911 Carrera
'05 Infiniti G35 coupe sport
Bosse'sBoss is offline   Reply With Quote
Old 09-14-2020, 05:16 PM   #10
Jsreo
 
Drives: 2017 2SS Manual
Join Date: Apr 2017
Location: Atlanta GA
Posts: 366
Purchased in April 2017, 32k miles currently

Literally zero issues (m6 so no potential for shudder issue)

Swapped out the run flats for ps4’s on Heico FF04 wheels because the run flats were not great

I have another car for bad weather days so the Camaro only goes out on nice days and for road trips
Jsreo is offline   Reply With Quote
Old 09-14-2020, 05:25 PM   #11
bigd1276
2017 HyperBlue 2SS
 
bigd1276's Avatar
 
Drives: 2017 HyperBlue Camaro 2SS
Join Date: Jan 2009
Location: Hanover, PA
Posts: 2,017
Purchased my 2017 2SS in September of 2016. Put over 7,000 sunny Sunday afternoon miles on her with 0 issues!
__________________
]
http://www.camaro5.com/forums/showthread.php?t=30755

2010 IBM 2LT RS......Traded for.....
2012 IBM 2SS RS......Traded for.....
2017 HBM 2SS
bigd1276 is offline   Reply With Quote
Old 09-14-2020, 05:43 PM   #12
LT4Greg


 
LT4Greg's Avatar
 
Drives: 2017 Camaro ZL1 Coupe
Join Date: May 2016
Location: Georgia
Posts: 5,020
So far no issues with my 2017 ZL1 that I bought used last year in March! The 2016 2SS I bought new in April 2016 no issues except for the half ass repairs done to the car by the body shop due to the front end accident I had 6 months after I bought it.
__________________
ZL1 Coupe, PDR, Exposed carbon fiber hood insert, My Link with Nav, M6 6 speed and Silver Ice Metallic. Mods done: ceramic window tint, GM Accessories Camaro floor mats and Roto-Fab CAI.
LT4Greg is offline   Reply With Quote
Old 09-14-2020, 06:10 PM   #13
HCI2000SS

 
HCI2000SS's Avatar
 
Drives: 2018 Camaro V6/RS
Join Date: Nov 2018
Location: MI
Posts: 1,595
I've had my 2018 for 2 years now, and it has almost 30,000 miles. Besides the A8 shudder (which hasn't returned after the latest fluid and flush procedure) I've had no issues. Car is solid with vibrations or anything. Run flats have about 20,000 miles on them, and probably have another good year left before replacing
HCI2000SS is offline   Reply With Quote
Old 09-14-2020, 06:21 PM   #14
Mike Aruba
 
Mike Aruba's Avatar
 
Drives: 2016 2SS
Join Date: Apr 2020
Location: Florida Man
Posts: 86
Anyone have any issues with the rear view camera? Mine gets a little static sometimes. Beside that and the slow crank, I havent had any issues with my car so far.
Mike Aruba is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:44 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2022, vBulletin Solutions, Inc.