Homepage Garage Wiki Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read
#Camaro6
Go Back   CAMARO6 > CAMARO6.com General Forums > ZL1 Discussions


BORLA


Post Reply
 
Thread Tools
Old 12-14-2016, 11:19 PM   #1
Lashu74
Lashu74
 
Lashu74's Avatar
 
Drives: 2017 ZL1
Join Date: Dec 2014
Location: PA
Posts: 188
Fitment and check engine light

So I picked up my zl1 last weekend drove 300 miles to get it, got a block from my house and it through a check engine light. Coming back as emissions anyone else have this issue? Also I noticed that the trunk mat does not fit properly in the rear trunk. It does not drop down into the opening like it should. Oh and lastly when cruising at 3-4K rpm when I gave it moderate acceleration it seemed like something was slipping and then it would pick up. Not sure if that has something to do with the emissions issue or if it's something else or if I'm just not use to a supercharged engine. I've had a few turbo cars that never reacted like this though. Any thoughts?
Lashu74 is offline   Reply With Quote
Old 12-14-2016, 11:27 PM   #2
KaBoom1701
KaBoom1701
 
KaBoom1701's Avatar
 
Drives: 13' ZL1 Red M6
Join Date: Dec 2012
Location: I.E. SoCal (Yucaipa)
Posts: 8,441
Seems like you have a few issues going on here...

With such a brand new car I'd be taking it back to the dealer ASAP.

Good luck.
__________________
Mods:
Roto-Fab Intake, WW Res. kit & Big Gulp Air Scoop, Elite Catch Can, ATI Super Damper & 18% OD Pulley, LF Idler pulley bracket, Metco CC breather, ID850 Injectors, Stainless Power Headers w/ ceramic coating, TR71X Spark Plugs, JMS Fuel Pump Booster, Bo White TB, Tuned by Ted @ Jannetty Racing, Ron Davis HX, D3 Reservoir, Pfadt 1" Springs, Moreno Camber Plates, ZL1 Addons Splitter guard washers, Tow Hook kit & rock guards, Hurst Shifter Billet Plus 6 Speed Short Shifter, ZL1 DRL lighting harness, ZL1 Recaro Seats.
KaBoom1701 is offline   Reply With Quote
Old 12-14-2016, 11:31 PM   #3
Lashu74
Lashu74
 
Lashu74's Avatar
 
Drives: 2017 ZL1
Join Date: Dec 2014
Location: PA
Posts: 188
I would if it wasn't 300 miles away I'm taking it into my local dealer tomorrow
Lashu74 is offline   Reply With Quote
Old 12-15-2016, 12:23 AM   #4
Android42019
The Black Emerald
 
Android42019's Avatar
 
Drives: '17 ZL1, '08 Trailblazer, '11 1LTRS
Join Date: Sep 2011
Location: DFW Metroplex
Posts: 719
Quote:
Originally Posted by Lashu74 View Post
I would if it wasn't 300 miles away I'm taking it into my local dealer tomorrow
Do a yelp search for a reputable dealership near you and take it in. They HAVE to fix it or possibly order you a new vehicle if things aren't fitting right, I'd be very particular about it if I were you, Good luck bud.
__________________
ZL1 Pix/Vids - Instagram: JZL15017
Android42019 is offline   Reply With Quote
Old 12-15-2016, 01:20 AM   #5
Quick_Wick
 
Quick_Wick's Avatar
 
Drives: 2017 ZL1 6 spd RED HOT w/ PDR
Join Date: Oct 2016
Location: Imperial Beach, CA
Posts: 129
What a shame. Good luck getting those issues fixed and let us know what happens.
Quick_Wick is offline   Reply With Quote
Old 12-15-2016, 08:38 AM   #6
17CamaroZL1
Life's Short, Live Fast!
 
17CamaroZL1's Avatar
 
Drives: 2017 Hyper Blue A10 ZL1
Join Date: Nov 2016
Location: London, KY
Posts: 1,448
The slipping feeling sounds like the engine stumbling a little for some reason. It definitely shouldn't do that. With the setup on these cars, throttle response should be instant, no hesitating and then picking up. I would guess the feeling you are describing is causing the emissions light. Almost sounds like possible faulty plugs or a couple of crossed plug wires, but crossed wires are a thing of the past with new engines. Could also be in the fuel system. Bad gas even. Good luck.
__________________
Life's Short, Live Fast! https://youtu.be/rTUv2p4T7OA 10.94 at 128 mph, 11.13 at 127mph 870 DA, https://youtu.be/e_X_LcpFp50 11.19 at 127mph 1100 DA, https://youtu.be/OXQiCQdQuH4 11.40 at 125mph 1800 DA
https://youtu.be/uWba1qs8M6Q 11.52 at 123mph 3500 DA
TZQPHG '17 ZL1 HBM|A10|Nav|PDR|CFW Hood|ZL1 Mats

12/26/2016 Ordered!
2/8/2017 Built!!
3/2/2017 Brought Home!!!
17CamaroZL1 is offline   Reply With Quote
Old 12-15-2016, 08:40 AM   #7
NB2017ZL1

 
NB2017ZL1's Avatar
 
Drives: 2017 ZL1 10 Speed Hyper Blue
Join Date: Jul 2016
Location: NB
Posts: 1,307
^^^^

Get her in and get her fixed up right!
__________________
2017 ZL1 & NISSAN GTR & RF
NB2017ZL1 is offline   Reply With Quote
Old 12-15-2016, 08:43 AM   #8
HyperBlueX2


 
HyperBlueX2's Avatar
 
Drives: '17 ZL1 HBM A10 '16 HBM 2SS Vert A8
Join Date: Dec 2015
Location: Millington, MI
Posts: 2,999
Using premium fuel I would hope?
__________________
TXVGJX '17 Camaro ZL1 Coupe Hyper Blue|A10|PDR|NAV|#23 A10|Ordered thru Becky D.


2016 Hyper Blue 2SS Convertible A8|2012 2SS Yellow Camaro Convertible LS3 M6(SOLD)|2010 Detonator Yellow Challenger R/T Classic A5(SOLD)|1987 Buick Grand National|1970 1 of 88 Beige Dodge Super Bee|2007 Impala SS LS4 Laser Blue(Given to son)|2017 Tahoe LT Blue Velvet|2016 Silverado Z71 Ocean Blue
HyperBlueX2 is offline   Reply With Quote
Old 12-15-2016, 08:52 AM   #9
24MaroSS
 
Drives: 17' Maro ZL1
Join Date: Jul 2016
Location: Atl
Posts: 29
With a new car - one like this - that dealer should have followed delivery instructions removing spacers, etc. If the check engine light is on and reporting emissions its possible that could affect the throttle 'slip'.

Keep us informed though.
__________________
Own: 17' ZL1 Black, CF Hood
Sold: 16' Maro SS
24MaroSS is offline   Reply With Quote
Old 12-15-2016, 09:41 AM   #10
DenverTaco07


 
DenverTaco07's Avatar
 
Drives: 2017 SS 1LE, 2017 Volt, 2013 Pilot
Join Date: May 2014
Location: Colorado
Posts: 3,530
hmmm...I hope it's just bad gas as mentioned. Code will hopefully explain both issues.
DenverTaco07 is offline   Reply With Quote
Old 12-15-2016, 10:48 AM   #11
Z_Rocks

 
Z_Rocks's Avatar
 
Drives: everyone crazy...
Join Date: May 2009
Location: SW Florida
Posts: 2,108
I bet the dealer to save a few bucks, put regular 87 gas in it. or one of the cylinders not firing properly.
Z_Rocks is offline   Reply With Quote
Old 12-15-2016, 11:21 AM   #12
jasonz28camaro
 
Drives: 2007.5 Duramax
Join Date: Nov 2016
Location: Houston
Posts: 44
What's the code number? Please share. Do some research on the code number, could be the culprit causing the laziness. Not sure if any emissions related codes would cause a limp mode of any type but it might? Also would be good to know what the code is telling you prior to going to a dealership so they don't Dick around with you.

Dealers are pretty good at customer crevice, I know, I used to do it for a living way back when. Just take some photos of the mat and send them to your dealer. Make sure to send it to the salesman, sales manager, etc... Someone will get back to you. Just say you want a new one ordered and sent you your house.
__________________
Built C6Z 600whp NA - SOLD
Built LSX 96SS - SOLD
jasonz28camaro is offline   Reply With Quote
Old 12-15-2016, 11:34 AM   #13
Lashu74
Lashu74
 
Lashu74's Avatar
 
Drives: 2017 ZL1
Join Date: Dec 2014
Location: PA
Posts: 188
Thanks for all the feedback, I was there when they filled the tank up and I said about putting premium in before he filled it. He said he would but I didnt check to see if he actually did. I refilled the tank 3/4 of the of the way home and filled it with 93. It may have still had a a little of the initial gas in it though when I got home. Im taking her in tonight to the dealer to drop her off. Ill def post how I make out. Im also in touch with Chevy cause this is total BS! I had an issue with my new 2015 ss 1le and I couldnt drive it for close to a month.They did take care of me in that case we'll see if they step up this time as well.
Lashu74 is offline   Reply With Quote
Old 12-15-2016, 11:38 AM   #14
Lashu74
Lashu74
 
Lashu74's Avatar
 
Drives: 2017 ZL1
Join Date: Dec 2014
Location: PA
Posts: 188
Not sure of the code number, I will try to get it before I drop at the dealer today. Onstar sent me a message saying it was emissions.
Lashu74 is offline   Reply With Quote
 
Post Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:51 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.